iPad2- YouTube poor performance

Discussion in 'iPad' started by HardLuckStories, Apr 11, 2011.

  1. HardLuckStories macrumors regular

    Joined:
    Oct 23, 2010
    Location:
    UK, Manchester
    #1
    Maybe its just me but why must I wait a total of 9minutes for a 40second clip to buffer on my ipad?

    I access the same video on my air (same wifi access point) and it plays without delay, its so bad on the ipad that I no longer use it to watch youtube which is a shame because this is a big feature for me and i had thought with the better specs of ipad2 vs 1 it would handle youtube easily.

    Maybe somethings wrong here, or do others experience poor performance regards youtube and buffering of video on ipad1/2?

    (Incidentally if I download a large app on ipad, the speed is equal to the air this issue seems solely affecting youtube vids)
     
  2. blueridge macrumors 6502

    blueridge

    Joined:
    Mar 14, 2011
    Location:
    Western NC
    #2
    never had that problem.. youtube seems to play almost immediately.. weird
     
  3. andybrown44 macrumors regular

    Joined:
    Mar 11, 2011
    Location:
    Hull, UK
    #3
    I used to have the same problem with my iPhone; when I upgraded to a wireless N router it stopped. If I used it on 3G it worked fine, since the app automatically lowered the quality of the video. As a temporary fix you can go to the YouTube website and use their 'web app', and disable High Quality. It should load fine but obviously won't look great.

    Have you tried it on a different WiFi network to your own? Did it work ok on there?
     
  4. HardLuckStories thread starter macrumors regular

    Joined:
    Oct 23, 2010
    Location:
    UK, Manchester
    #4
    Yea you're right it seems the quality is HD on ipad, hence very slow to buffer whereas air uses chrome and only 360p so much faster. I'll put it down to slow internet access. Will try on other networks to see if can gain any improvement. Youtube through Safari is actually pretty adequate.
     
  5. Pared macrumors 65816

    Joined:
    Oct 19, 2007
  6. KHC831 macrumors member

    Joined:
    Mar 15, 2011
    #6
    How did you get YouTube in safari? Mine always switch to the YouTube app whenever I click on a youtube link.
     
  7. M-5 macrumors 65816

    M-5

    Joined:
    Jan 4, 2008
    #7
    Typically, if you click on a YouTube link from a Google search it will throw you into the stock YouTube application. But you should just be able to go to youtube.com on safari and play the videos from there. It will redirect you to the mobile site however, since the desktop version of the YouTube website requires flash to play the videos. On the mobile site, you can toggle the HD quality of videos.
     
  8. jafingi macrumors 65816

    jafingi

    Joined:
    Apr 3, 2009
    Location:
    Denmark
    #8
    Youtube performance has always bugged me. On my Macbook Pro, iPhone and iPad.

    Even though I have a 100/100mbit connection, which would download with about 12MB/s (with no interference, only one user, and a quick server etc.), I download from Youtube with about 120-400kb/s.

    I found, that using OpenDNS reduced the speed dramatically.. After removing those OpenDNS binds it became quick again.. But now, it's slow again.

    Guess the problem is at Google.. Their speeds are very unstable. Live with it :mad:
     

Share This Page