iPhoe won't charge :(

Discussion in 'iPhone Tips, Help and Troubleshooting' started by shagggz, Mar 13, 2012.

  1. shagggz macrumors newbie

    Joined:
    Feb 7, 2011
    #1
    My iPhone 4 was down to about 3% so i plugged it into the (work) computer to charge and the charging symbol came up but it didn't go up from 3% and eventually ran out of battery. One thing I immediately noticed that was different when I first plugged it in was that the charging icon in the top right corner looked different, no longer the thunderbolt but a plug. I tried plugging it into the wall but still only the thunderbolt sign would show up. I tried the computer again and same thing; it wouldn't even recognize that it was plugged in, so I tried putting it into DFU mode, which then made iTunes recognize it, but it said I had to restore and download the latest iOS version, which I did, which didn't help. When I got home I tried plugging it in again, to the wall, with a different USB cord and it worked. Okay, problem solved, I thought... it's just a faulty USB cord. Well, a couple days later, it runs out again, so I plug it into the wall with the cord that worked and it no longer works. I tried using this same cord on my computer and still it doesn't work. I tried a bunch of other USB cords (I've accumulated a bunch over the years...) to no avail. I doubt it's an issue with the battery as I've only had this phone for a year, and it seemed to hold about the usual amount of charge in the last couple days that it was working again. I can't take it to the apple store. Any ideas? I'm thinking it's some sort of software issue, but have run out of ideas on what to do...
     
  2. bmacir macrumors 6502

    Joined:
    Apr 2, 2009
  3. shagggz thread starter macrumors newbie

    Joined:
    Feb 7, 2011
    #3
    its jailbroken and out of warranty and has taken a couple dunks in the past.
     
  4. bmacir macrumors 6502

    Joined:
    Apr 2, 2009
    #4
    you said you restored it, so it's not jail broken any more. If you jail broke it you can restore it again.

    If you have a hardware fault your only option is take it to a repair shop (either authorized or not). If it's out of warranty you will have to pay for it.
     
  5. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #5
    It's not a software issue,'since you restored it in DFI mode.
     

Share This Page