iPhone & 02 Simplicity not working

Discussion in 'iPhone' started by DTG, Jun 24, 2009.

  1. DTG macrumors member

    Joined:
    Oct 5, 2003
    Location:
    UK
    #1
    I've been reading around this subject rather a lot and it seems that most people have had no issue with putting their 02 Simplicity SIM card into their iPhones.

    My story is this: I already have an 02 Simplicity SIM card that I use with my unlocked Nokia 6300. I purchased a used iPhone 3G (PAYG) from eBay and tried using my Simplicity SIM in it. The iPhone has been restored and updated to OS 3.0 so it's all fresh in that regard. However, no luck. Having inserted the SIM I am greeted with the message: "SIM locked" and then prompted to enter a 3-digit code before I can use the phone. I've not attempted this code as I don't want to get my SIM deactivated (you get three attempts).

    Does anyone have any advice on what to do next?

    My initial thoughts are that my SIM card is quite old (from 2004) and was originally on a different 02 contract, so when I changed to Simplicity they simply changed my tariff. Perhaps I need a new SIM from 02?

    I've tried unlocking and JBing. No luck there either. So I really don't know what's going on.
    Any other suggestions?

    Cheers,
    DTG.
     
  2. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #2
    You just need to unlock the sim card itself. It seems its been locked with a pin by you or someone else with access to it
     

Share This Page