iPhone 1.1.3 deleting mail off my server? WTF?

Discussion in 'iPhone' started by NJRonbo, Jan 18, 2008.

  1. NJRonbo macrumors 68000

    Joined:
    Jan 10, 2007
    #1
    Something I just noticed with my 1.1.3 upgrade....

    When I delete mail off my iPhone, it also deletes it off
    my mail server.

    This never happened prior to 1.1.3 and I'm not happy about it
    as I need the same access to those email messages when I
    switch to my laptop and desktop.

    Any suggestions?
     
  2. Vegantnt macrumors newbie

    Joined:
    Sep 23, 2007
    #2
    if your iphone is deleting mail off your server than you most likely have it set for IMAP instead of POP3

    were you using one of the services offered in the set menu of the mail app? Gmail, aol, yahoo, etc.

    gmail used to be set at POP3 by default but in the 1.1.3 firmware it is now set to IMAP by default. that may be the problem.
     
  3. kyrow123 macrumors member

    kyrow123

    Joined:
    Oct 9, 2007
    Location:
    Boston, MA
    #3
    First off, I am assuming you are using Gmail. This happens because it now uses IMAP to sync your mailboxes on every computer and device you access your mail account from. What you can do, is instead of delete the mail off of you phone is click on the folder button when the email is opened on the iPhone and then file it into one of the mail folders that are associated with your email account. That will store the mail in a folder and sync back to you online account.

    Hope that helps!
     
  4. NJRonbo thread starter macrumors 68000

    Joined:
    Jan 10, 2007
    #4
    You guys guessed right. I am using GMAIL to sift out all the spam.

    Can I just switch it back to POP3? How do I do that on the iPhone?

    Also, can someone give another explanation of what Kyro was
    explaining if I am forced to go that route? I am not quite sure
    what he was suggesting I do as far as folders are concerned.

    Thanks for the help!
     
  5. NJRonbo thread starter macrumors 68000

    Joined:
    Jan 10, 2007
    #5
    GMAil has posted instructions on fixing this problem
    but it doesn't quite make sense.

    The second step is "Tap OTHER"

    When I tap on the MAIL icon from my HOME screen
    I see no OTHER option. What are they saying here?
     
  6. nippyjun macrumors 65816

    Joined:
    Jul 26, 2007
    #6
    This question is on the subject of mail but a little different. Where do i find instructions on how to make it look as if i'm sending my email from my schools email but going through gmail? I have gmail set up to retrieve my school email and set it up so that replies go through the account that they came through. But how do you set up the iphone to complete the process?
    Thanks.
     
  7. jasonbuzz macrumors newbie

    Joined:
    Jun 26, 2007
    #7
    Under Settings --> Accounts in gmail, you can check the option that says "Reply from the same address the message was sent to." You also have to provide your school address to be able to do this. The problem with this option is you can't do this on the iPhone and there is always some reference to your gmail address even when you reply from the gmail interface.

    I was able to use Yahoo Plus to do what you're trying to do in gmail. Yahoo plus cost $20 but it was worth to be able to check my corporate mail (via autoforward) on the iPhone and respond as if I had responded from my work computer (Dell laptop...ughh).
     
  8. iFerd macrumors 6502a

    Joined:
    Jul 20, 2007
  9. NJRonbo thread starter macrumors 68000

    Joined:
    Jan 10, 2007
    #9
    Okay...

    It looks like I fixed the problem.

    I deleted the current GMAIL account on my iPhone.

    I then created a brand new POP3 account under mail
    settings using the "other" option described above.

    Incoming mail: pop.gmail.com

    I used my own mail server for the outgoing address.

    This seems to have fixed the problem. I am receiving all my
    email and can readily delete it without worrying that it is also
    being deleted off of the server.

    One last thing...

    Damn Iphone! Whose bright idea was it to screw this up?
     
  10. ifonline macrumors regular

    Joined:
    Jun 25, 2007
    Location:
    Braselton, Georgia
    #10
    This is typical IMAP behavior... synced mailboxes for Inbox, Sent, Drafts, and Trash. Nothing new or surprising. It makes me laugh when people post "fixes" for this behavior, as this is the intended behavior.

    Personally, I love IMAP... beats the pants off POP3. I have synced e-mail across my iPhone, desktops (2), and notebook. Whatever I do on one is mirrored on the others. Brilliant.
     
  11. imacdaddy macrumors 6502a

    Joined:
    Feb 2, 2006
    #11
    This sort of behavior with IMAP and gmail happened to me before using another phone. I deleted an email from my phone and it sync'd back to gmail.

    So to prevent accidental deletion, I just created another gmail account. It's my mobile account to use on phones. All mail sent to my main gmail will also be forwarded to my mobile gmail account, thus I have 2 copies. This can be configured within gmail. My IMAP on my iPhone is set up to sync with my mobile gmail account and whatever I do in mail on my iPhone wont mess up my main gmail account. And if you're wondering, my mails sent out through iPhone uses my main gmail address. This can be done on gmail and iphone.
     

Share This Page