iPhone 1.1.3 Message Order - APPLE FIX

Discussion in 'iPhone' started by scb02, Jan 30, 2008.

  1. straff2002 macrumors newbie

    Joined:
    Jan 6, 2008
    #2
    A fix that actually works (for JB phones as you need SSH)
    SSH into root of phone
    rm /var/db/timezone/localtime
    ls /usr/share/zoneinfo/Etc/

    get the code for your timezone and remember it (mine is GMT)

    ln -s /usr/share/zoneinfo/Etc/(code) /var/db/timezone/localtime

    mine was ln -s /usr/share/zoneinfo/Etc/GMT /var/db/timezone/localtime


    props to rgates on the MMi forums for this
     
  2. hollerz macrumors 6502a

    hollerz

    Joined:
    Sep 13, 2006
    Location:
    Durham, UK
    #3

    Can anyone confirm this? I'm having the same issue!
     
  3. nickspohn macrumors 68040

    nickspohn

    Joined:
    Jun 9, 2007
    #4
    1) posted on Apple's site days ago
    2) Been other threads on this fix
    3) Engadget was late on posting the fix
    4) This was also posted in Macrumors iPhone blog.




    This works for like 2% of people too, if that. Sorry to sound like a jerk, but this fixes nothing.
     
  4. straff2002 macrumors newbie

    Joined:
    Jan 6, 2008
    #5
    Nick, did you not find that editing the timezone through ssh work? instantly fixed it for me!
    Straff
     
  5. hollerz macrumors 6502a

    hollerz

    Joined:
    Sep 13, 2006
    Location:
    Durham, UK
    #6
    I just tried it, will let you know how it works for me!

    EDIT: Did it move all your existing messages into the correct order or just the new ones? All my existing ones are still in the wrong order.
     
  6. nickspohn macrumors 68040

    nickspohn

    Joined:
    Jun 9, 2007
    #7
    I don't have a JB iPhone anymore, so i can't try it :(
     
  7. labcondave macrumors newbie

    Joined:
    Jan 30, 2008
    #8
    Me neither

    I had previously fixed this by setting my iphone time to the official atomic clock time on www.time.gov

    When the apple fix was published, i tried it and it made the problem re-appear!

    set the time back to the atomic clock and it is working... one thing is though, there doesn't seem to be a way to set the time to the exact second.
     
  8. East macrumors member

    Joined:
    Dec 22, 2007
    #9
    yeah it works and i am glad i hated that all my text where out of order.
     
  9. straff2002 macrumors newbie

    Joined:
    Jan 6, 2008
    #10
    hollerz yeah it's only your new ones that will be fixed
    Cheers
     
  10. hollerz macrumors 6502a

    hollerz

    Joined:
    Sep 13, 2006
    Location:
    Durham, UK
  11. Vikash macrumors member

    Joined:
    Oct 12, 2007
    #12
    So what is Amsterdam, GMT+1 or CET?
     

Share This Page