Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

centaurachiron

macrumors newbie
Sep 26, 2021
6
0
Updated my iPhone 11 to iOS 15, drove to store with no issues with Carplay. While there, I activated my new iPhone 13 mini (and disabled the 11) and now Carplay does not work. Trying to play any music causes it to crash and not come back. Unpaired and re-paired the phone, powered phone off and on a bunch of times, reset the stero/display, tried new cable, nothing works. Now I drive in silence, and it's miserable. I have a 2020 Forrester (Subaru). Anyone else have the same problem? I can use the maps through the iPhone on Carplay but I have to be careful not to let iTunes start up or it crashes again and cannot be brought back NOR can I connect the car to wifi (which slows the maps down considerably).
 

rmm805

macrumors member
Dec 7, 2014
96
41
My iPhone 13 pro works perfectly fine in my car on wireless CarPlay. The same phone in my wife’s wired CarPlay experiences frequent disconnects. I did reset all setting and turned off EQ but no difference.
 

Ak47danny89

macrumors newbie
Sep 25, 2021
3
0
Updated my iPhone 11 to iOS 15, drove to store with no issues with Carplay. While there, I activated my new iPhone 13 mini (and disabled the 11) and now Carplay does not work. Trying to play any music causes it to crash and not come back. Unpaired and re-paired the phone, powered phone off and on a bunch of times, reset the stero/display, tried new cable, nothing works. Now I drive in silence, and it's miserable. I have a 2020 Forrester (Subaru). Anyone else have the same problem? I can use the maps through the iPhone on Carplay but I have to be careful not to let iTunes start up or it crashes again and cannot be brought back NOR can I connect the car to wifi (which slows the maps down considerably).
Try turning off the eq. Settings > Music > EQ set to off. This worked for me. I tested it after making this change and I was working I went back to the EQ and set it back to late night and then the problem started but went away after I said it back to off.
 

centaurachiron

macrumors newbie
Sep 26, 2021
6
0
Turning off EQ worked! Thanks! Hopefully this is fixed so I can use the EQ as well, but what a relief. I haven’t tried using the map at the same time yet but I will and update.
 

Phunkfan

macrumors newbie
Sep 25, 2021
3
0
Turning the EQ to a different setting and playing music while not connected to the car and then turning back off worked for me.
 

AYoung

macrumors newbie
Sep 27, 2021
1
0
Thankyou. Turning late night eq to off fixes the problem.
I was having the same problem with music. My phone app was working and everything else was working through CarPlay, so I figured it had something to do with the Music settings. I did the same thing, but I didn’t turn the EQ off, instead I switched it to another EQ setting and it worked. Music starting playing through CarPlay. So glad it works now.
 

happy orchard

macrumors 6502
Jun 3, 2020
465
638
First time I ever used Apple Car Play was today with my 1st iPhone ever the 13 Pro Max. Wired. Was able to use Google maps (use to it from Android Auto), and listened to music via the spotify app in carplay. Didn't try to run any media directly on the phone if that is what you guys are talking about. For me, I had zero issues with anything with Carplay. In fact, I like it for the most part more than Android Auto. Well having full screen on my portrait big screen radio deck was awesome unlike my Android Auto setup that was 1/2 screen for AA only. The one thing I haven't found is a way to hide icons in carplay that I won't ever use likely and only have the ones I plan to use. AA I could do that. I guess I'm just reporting that I had no such issues today. I did install the OS Security patch update that was available on Day 1.
Don't know if this helps you the way you're wanting, but you can rearrange the apps so that apps you care about show up first/earlier:

General >> CarPlay >>[under My Car, choose your car]>>Customize and then you'll see the included apps first and below ones you can add. You can also use the three lines on the right margin to rearrange the order in which they appear, so you can keep your favorites on the first page that shows up on your car's screen.
 

SirWill

macrumors member
Sep 13, 2021
40
61
Pacific Northwest
Don't know if this helps you the way you're wanting, but you can rearrange the apps so that apps you care about show up first/earlier:

General >> CarPlay >>[under My Car, choose your car]>>Customize and then you'll see the included apps first and below ones you can add. You can also use the three lines on the right margin to rearrange the order in which they appear, so you can keep your favorites on the first page that shows up on your car's screen.
I actually found just 15 minutes ago before seeing this where to re-arrange and to even remove some apps! Just what I wanted. Sadly can't remove all the ones I want removed but the order change helps a lot.
 

Raizzenbran

macrumors newbie
Sep 27, 2021
1
1
Before reseting all settings, try going to Settings>Music and changing EQ to off. I had the same issue where everything on the wireless Apple CarPlay worked until I tried to play any type of music, from any app. I reset my settings and it worked, but as I was going through putting my settings the way I had it, I put EQ (equalizer) to Late Night and the music shut off and CarPlay disconnected once again. I switched it back to off and it stayed connected again.
This absolutely worked. So interesting. Thanks so much! This is the fix everyone!!
 
  • Like
Reactions: KnifeParty

Zucchini

macrumors newbie
Sep 27, 2021
1
1
I made an account to say thank you! I tried everything I could think of and was still having errors. Changed the EQ, now it works. I never would have thought of that.
 
  • Like
Reactions: happy orchard

KnifeParty

macrumors newbie
Sep 7, 2020
5
0
Before reseting all settings, try going to Settings>Music and changing EQ to off. I had the same issue where everything on the wireless Apple CarPlay worked until I tried to play any type of music, from any app. I reset my settings and it worked, but as I was going through putting my settings the way I had it, I put EQ (equalizer) to Late Night and the music shut off and CarPlay disconnected once again. I switched it back to off and it stayed connected again.
Dude thank you so much, it worked like a charm!!! I tried everything and was dreading doing the “Resetting All Settings” fix. Great observation bud, would never have guessed this fix in a million years. Cheers!
 

JohnnyChuttz

macrumors regular
Oct 31, 2017
143
115
Anyone else forced to unlock the phone every time it’s plugged in to CarPlay? I have the USB accessory toggled “On” in FaceTime and Passcode. Didn’t change any settings from my 12pro and it worked flawlessly. 13Pro on 15.0.1.
 

centaurachiron

macrumors newbie
Sep 26, 2021
6
0
Yes, I noticed over the last few days I have had the prompt to unlock my phone to use CarPlay despite the fact that I have it set to allow most apps when the phone is locked. It happens about 50% of the time I start up my car. I also get the prompt to "allow access when locked". It's a bit unpredictable.
(I tried other EQ settings and for me also it is ONLY the Late Night EQ that crashes CarPlay immediately. Other settings worked. I am calling this The Late Night Bug.)
 

marzfreerider

macrumors 6502
Jun 13, 2014
337
216
Canada
Anyone else forced to unlock the phone every time it’s plugged in to CarPlay? I have the USB accessory toggled “On” in FaceTime and Passcode. Didn’t change any settings from my 12pro and it worked flawlessly. 13Pro on 15.0.1.
Go to Settings, General, CarPlay, choose your vehicle and look to see if the toggle for Allow CarPlay While Locked is on or off. If its off that's why you have to put in your passcode or Face ID before it works. Turn on will let you just plug in and work. I personally keep this off.
 

JohnnyChuttz

macrumors regular
Oct 31, 2017
143
115
Go to Settings, General, CarPlay, choose your vehicle and look to see if the toggle for Allow CarPlay While Locked is on or off. If its off that's why you have to put in your passcode or Face ID before it works. Turn on will let you just plug in and work. I personally keep this off.
Wow, thank you so much. That was switched off. A google search only turned up the USB Acc, setting in Passcode.
 

bsmsam

macrumors regular
Jul 22, 2008
100
32
Just here to say thank you! I don't even use CarPlay, but my 13 Pro wouldn't connect music to my car (Mini Cooper r56). I was getting super frustrated and considering returning the device because I can't return my car, haha. I also use Spotify and not the Music app, and EQ was already off, but I toggled it on and back off anyway, and my music instantly worked. Thanks!
 

djtommyf

macrumors newbie
Nov 8, 2014
14
2
Good morning.. I try reset, i have already disabled EQ, but carplay can't work.. spotify and calls reset everytime... I have a new 13 pro with 15.01... with 12 pro max no error ...
 

centaurachiron

macrumors newbie
Sep 26, 2021
6
0
I updated today to 15.1 (got the new AirPods, and was prompted to) and now CarPlay wont connect again, and the EQ has been off all this time. Has anyone else had this happen again?
 

roberthodgson

macrumors 6502
Jul 18, 2010
324
71
I just bought a car2play adapter for my subaru and tried it for the first time today, I have to say I really like having wireless carplay now and it works flawlessly with my 13 pro max ( at lease in my short test)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.