iPhone 2.1 issues appearing after 2 days of use...

Discussion in 'iPhone' started by acaullier, Sep 14, 2008.

  1. acaullier macrumors newbie

    Joined:
    Jul 22, 2007
    Location:
    Japan
    #1
    Hi all,
    after 2 days using iPhone Software 2.1, I noticed the following issues :
    - Contacts lag re-appeared : I have a 3 seconds lag when opening the Home->Contacts app (lag=time elapsing before you can actually scroll through contacts). This lag does not appear in the Home->Phone->Contacts app (it was the same behaviour in 2.0 version).
    - Memory problem : I opened TruPhone app tonight and got this error popping up (see screenshot below)
    - a french website (macbidouille.com) is reporting a security issue : if you lock you iPhone, you can still dial any phone number, not only emergency ones. I didnt test it though.

    2.1 is still better than 2.0 but I hope they will continue fixing issues at a fast pace.
    Did you notice these issues too, or even other ones ?
     

    Attached Files:

  2. FJR macrumors regular

    Joined:
    Jul 21, 2008
    #2
    If the issues are really bothersome, I'd try a full restore.

    2.1 has only brought improvements for me, and I wasn't having very many issues (none remotely serious) before. battery life went from good to great, no "memory leak" issues thus far and the apps installing/loading faster has been a godsend.
     
  3. BlackEyedOnly macrumors newbie

    Joined:
    Sep 14, 2008
    #3
    - from 3G to EDGE and then to nothing doesn't go to data services back anymore. I can make a call but cannot retrieve mail. Have to activate Flight and deactivate to restore a data connection.
    - sometimes I have a spontaneous SIMlock so therefore no connection until I unlock.
     
  4. alFR macrumors 68020

    Joined:
    Aug 10, 2006
    #4
    That isn't a bug, it's meant to work that way: you might need to call another number besides 911, 999 etc. in an emergency (e.g. local coastguard, mountain rescue, family, etc.).
     
  5. Wisenos macrumors newbie

    Joined:
    Aug 28, 2008
    #5
    me and my brother tried it... and you can call where ever ou want
     
  6. acaullier thread starter macrumors newbie

    Joined:
    Jul 22, 2007
    Location:
    Japan
    #6
    Just to be more precise : my 2.1 is a full restore, not an upgrade from 2.0
     
  7. periahdark macrumors member

    periahdark

    Joined:
    Aug 18, 2008
    #7
    i have also noticed that when i tap a third party app, it stays pressed for about 1 second then the app launches. The native apps open up immediately. Its nothing big but it really annoys me
     
  8. SoSII macrumors member

    Joined:
    Jul 19, 2008
    #8
    have you tried resetting network settings??
     
  9. BlackEyedOnly macrumors newbie

    Joined:
    Sep 14, 2008
    #9
    Yes, tried, thanks. Had no luck. Also today same problem. Switches from 3G to EDGE and back and once it hits no connection, the connection is never restored (calling however is still possible).
     
  10. luigi408 macrumors 6502

    Joined:
    Jun 22, 2008
    #10
    I haven't gotten any lag but I still have some crashes. For example safari crashes once in a while still not as often as it did before. When typing up an email it also crashed on me once. There are other crashes I have gotten after a clean 2.1 update.
     
  11. Masquerade macrumors 6502a

    Masquerade

    Joined:
    May 16, 2007
    #11
    Will iPhone get a memory indicator on the right-top-corner like the battery
    does?!
     
  12. ntrigue macrumors 68040

    ntrigue

    Joined:
    Jul 30, 2007
    #12
    Every issue on this page is third-party or null. The low memory is an issue with the app; not the firmware. Are you syncing Contacts through MobileMe, exchange, or iTunes?
     
  13. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #13
    For me it's more like a second while it pulls up the contacts list. Not really sure if this is a bug more than it is simply the phone opening a database. If someone has a long contact list, then I think it's reasonable to expect that the phone may take a couple seconds to get it loaded up.

    I would say count your blessings on this one. When I had a Treo 750, one of the early bugs was that the phone would take forever to look through your contact list to match caller ID's from incoming calls to any names that match that number. Until that happened, the phone would not ring, because it didn't know what name to display alongside the number. It was possible to completely miss a call on the Treo 750 because it took so long to match a name to the number that it never actually rang.

    Is this only happening with TruPhone? If so, then maybe it's a problem with the app. If other apps were doing it, then maybe I would think it's an OS bug.

    Confirmed. Someone else on this thread says this was intended, but I have to disagree with that. If it's a true emergency, you call 911. Calling your friend to say "ZOMG I FOUND SOMEONE'S IPHONE I THINK I'LL KEEP IT!!!!" is not an emergency. And no other phone I know behaves this way.


    At least 2.1 didn't introduce any dealbreakers, and managed to fix the bugs that were for some people here. Since a bug to circumvent the password lock existed in 2.0-2.0.2., I'd say that bug isn't really fixed, just kinda shifted a little.

    In any case, the keyboard lag is gone and has stayed gone, which was my main complaint, really. I'm happy with that.
     
  14. automatickyle macrumors regular

    Joined:
    Oct 19, 2007
    #14
    You might want to go take your phone in to get it checked out. It could be a bad antenna or something along those lines. I had a bad antenna with my first phone and had it switched out.
     
  15. Niiro13 macrumors 68000

    Joined:
    Feb 12, 2008
    Location:
    Illinois
    #15
    This is simply the program launching and the time it takes to get the entire database.

    I think the phone application is different, because who knows? It might be the sole program (other than the iPod program) that runs in the background. It wouldn't take up that many resources. I've noticed that it seems to be the one program that seems to load once, then never needs to load again. If you notice, the Stocks program has that same lag that the Contacts program does.
     
  16. michael31986 macrumors 68030

    Joined:
    Jul 11, 2008
    #16
    sms takes a second longer, but its not that serious.
     
  17. Kirbdog macrumors regular

    Kirbdog

    Joined:
    Feb 3, 2005
    Location:
    Whistler, British Columbia, Canada
    #17
    external speaker stopped working

    I just noticed this evening that the external speaker stopped working.
    The phone still rings. But will not output sound when playing iTunes, from YouTube or games!!
    Tried a reboot but still no dice.

    Anyone else had this happen?
     
  18. ntrigue macrumors 68040

    ntrigue

    Joined:
    Jul 30, 2007
    #18
    Sometimes you have to 'mess' with the headphone jack. Trying inserting/removing the headphones repeatedly or use compressed air.
     

Share This Page