iPhone 2.1 safari links to AppStore no longer work

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ScottP, Sep 15, 2008.

  1. ScottP macrumors newbie

    Joined:
    Jun 9, 2008
    #1
    Prior to upgrading my iPhone 3G to 2.1 if I selected a link to the AppStore on a webpage in safari it would launch the AppStore on my iPhone. However, now when safari tries to go to the "phobos.apple.com" link I just get back a dialog saying ... Cannot Open Page "Safari cannot open the page because the address is invalid".

    Anyone have any clues as to where this error is coming from???
     
  2. jwflutterby macrumors regular

    Joined:
    Jul 9, 2008
  3. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #3
    Wirelessly posted (iPhone 3G (16GB, 2.1 PWNed): Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_1 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5F136 Safari/525.20)

    Same here. :(
     
  4. andreab35 macrumors 6502a

    andreab35

    Joined:
    May 29, 2008
    Location:
    USA
    #4
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_1 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5F136 Safari/525.20)

    Same here. I wanted to download istockmanager from a link to the App store and it didn't work.
    However, you can access the links fine on a computer and download your desired app from iTunes.
    Hope it gets fixed soon!
     
  5. inblosam macrumors newbie

    Joined:
    Dec 30, 2003
    Location:
    St. George, UT
    #5
    Same problem here

    Just realized it wasn't working today and found this thread. C'mon Apple!
     
  6. gaina macrumors newbie

    Joined:
    Jul 6, 2007
    #6
    Wtf

    Still broken as of today. What is the world is the problem with Apple? People are probably losing tons of sales.

    FIX IT ALREADY!
     
  7. cclaan macrumors newbie

    Joined:
    Oct 19, 2008
    #7
    Any news on this issue?

    Does anyone know if this issue has been addressed yet? It's more than a month after this thread started, seems like a problem apple would care about.

    thanks
     
  8. amlweems macrumors newbie

    Joined:
    Aug 16, 2007
  9. filterban macrumors member

    Joined:
    May 5, 2006
    #9
    Are you sure? This is really putting a damper on my iPhone App listing site's ability to work for Mobile Safari users!
     
  10. SenatorOmelet macrumors newbie

    Joined:
    Sep 19, 2008
    #10
    Wow it has been broken this long!

    I just figured out that the App Store links were broken under Mobile Safari. They have been broken since 2.1 and Apple still hasn't fixed it? That is terribly unresponsive.
     
  11. ethana macrumors 6502a

    Joined:
    Jul 17, 2008
    Location:
    Seattle, WA
    #11
    Can anyone with the 2.2 beta firmware confirm if this is fixed or not? Or did Apple make this change on purpose for security reasons?
     
  12. nothappyatall macrumors newbie

    Joined:
    Nov 27, 2010
    #12
    first time to purchase using my iPhone

    and I get this error! how frustrating! they are partnering with booksonboard you would think they would treat fixing this issue with priority?
     

Share This Page