iPhone 2.2: Mail cannot delete any e-mails

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Khryz, Nov 25, 2008.

  1. Khryz macrumors 6502a

    Joined:
    Jan 7, 2007
    #1
    Every since the 2.2 update, when I try and delete any e-mail on any of my different e-mail accounts (gmail, aol) it says it is unable to move the messages to the trash. This is with every single e-mail and it's a little annoying.

    Can someone tell me why it's doing this?

    Thanks.
     
  2. LAND15 macrumors newbie

    Joined:
    Nov 27, 2008
    #2
    I'm having the same problem and it's driving me crazy. The Apple website doesn't offer any info on the issue.
     
  3. brian4610 macrumors regular

    Joined:
    Jan 10, 2005
    #3
    i wasn't able to delete emails either, i'd delete them on the phone, but the mail app would freeze and i'd have to start over. I finally got it to work when i deleted one by one and not multiples at once.

    since 2.2, my phone is REALLY buggy. apps take a while load, often crash, and a general lack of overall performance post update.

    surprising considering that the update was a basic one you'd think that they'd have gotten it right....
     
  4. Poat84 macrumors 6502

    Poat84

    Joined:
    Nov 21, 2008
    #4
    Should I download 2.2 or leave my phone as it is?
     
  5. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #5
    I'd wait at least a year if I were you.:rolleyes:

    How can anyone else answer this question for you?

    I don't have any problems deleting mail, either single ones or multiple ones. I had no problem jb-ing either.
     
  6. ILBandit macrumors regular

    Joined:
    Sep 7, 2008
    #6
    I had the "can't delete" problem once a while back also on my exchange account, and a gmail account.
    I deleted each mail account off of the phone, then put it back in again right after, and let it set up fresh. And everything worked fine after that. It got rid of the email that wouldn't delete, and has worked fine ever since then.

    Might be worth a try for you, beats doing a restore.
     
  7. roxychicx23 macrumors newbie

    Joined:
    Jul 10, 2008
    #7
    If you go to settings > mail > choose aol account > advanced > then delete messages > reclick on trash in iPhone... It should already have a check mark but do it again and it should solve the deleting messages problem
     
  8. kmacn60 macrumors newbie

    Joined:
    Dec 5, 2008
    #8
    Good Answer!

    I've had the problem (Unable to delete any mail) with my new 3G and my 2G that I gave to my wife. I just tried re-clicking the trash selection in ADVANCED and I'm back to deleting mail. Thanks!
     
  9. Punk Masen macrumors newbie

    Joined:
    Dec 5, 2008
  10. mphare macrumors newbie

    Joined:
    Apr 8, 2009
    #10
    Interesting fix, but it's not helping me.

    I have an iPhone 3G.
    I have two email accounts, one pop the other is set up for imap.

    The pop account has no problem deleting email.
    The imap account can delete email if I set the iPhone to use a local trash bin on the iPhone. But then it doesn't remove the file from the server.
    I get the "Unable to Move Message" (to mailbox Trash) message.

    I also cannot move email from the inbox to one of the folders I set up on the imap server. I get the same "Unable to Move Messages" (to mailbox Keep) in this example.

    I also cannot read email in any of the folders I set up on the imap server.
    I get a "Unable to Get Mail" (The connection to the server pop.***.com failed). Yet, I can read mail in the inbox, so I know I'm accessing the server.



    All of this worked prior to the 2.2 upgrade.
     
  11. mphare macrumors newbie

    Joined:
    Apr 8, 2009
    #11
    I solved the problem, I guess, by deleting the mail profile and re-creating it.
     

Share This Page