iPhone 2G 2.2.1 Jailbroke/Unlocked -- No WiFi

Discussion in 'Jailbreaks and iOS Hacks' started by alanisrox69, Mar 14, 2009.

  1. alanisrox69 macrumors regular

    Joined:
    Jul 10, 2007
    #1
    I've seen other users reporting no WiFi when unlocking and jailbreaking a 2G iPhone with the current OS, 2.2.1. I used QuickPwn and now the iPhone's WiFi doesn't last for more than a minute, or just says "Unable To Connect To (Network)". So frustrating!

    I've tried the following:
    1. Erase All Content And Settings (took forever) -- and afterwards I had to put in DFU mode and Restore, otherwise I just got the Apple boot logo with a spinning circle.
    2. Restored to 2.2, unlocked. Still no WiFi.
    3. Restored to 2.2, used Custom Firmware made in Pwnage -- Still no WiFi.
    4. Downgraded all the way back to 1.1.4, used kiPhone to activate, downgraded the baseband to 04.02.13_G (with winpwn), and then restored to 2.2, and then unlocked in QuickPwn. Still no WiFi.

    Any ideas how to fix WiFi?

    Thanks!

    -Derek-
     
  2. alanisrox69 thread starter macrumors regular

    Joined:
    Jul 10, 2007
    #2
    Anyone else have this problem and fixed it?

    -Derek-
     
  3. defiantmacho macrumors newbie

    Joined:
    Mar 30, 2009
    #3
    WiFii and 2.2.1 fix... at least worked 4 me!

    DO NOT DESPAIR. I HAD THE SAME ISSUE AND THIS IS WHAT SOLVED IT FOR ME. Firmware 2.2.1, well, sucks when it comes to WiFi functionality. I am doing a copy/paste of my very own solution. I am posting this on different sites so it reaches as many people as possible in the shortest time.

    Here's the final solution I found by old fashioned trial and error (AND what a pain in the butt it was to figure out). It worked, is still working and in full WiFi strength!
    I have a Netgear WGR614v6 wireless router, but I suspect it will work fine with most routers, specially Netgear.

    This is what I did:
    1- I logged into my "WiFi Access Point/Router" (Meaning the website where your router's settings are). In my case it is 192.168.1.1 (This is the set Access Point for my router. You'll need to find yours. It should be located on the back label of the router itself.
    2- Once I logged into the router's "Access Point" site, I went into "Wireless Settings" located in the menu on the left pane of the screen.
    3- Here I chose "WPA-PSK..." as the security to be used, AND, I entered a PASSWORD. This is to maintain the Network Secure and block leachers from using my internet for free!
    Don't forget to "Apply" the changes before going to the next step, and wait for it to finish will you? It will need a few extra seconds after it completes (the little antenna lights up on the router). MAKE SURE YOU WRITE DOWN THE PASSWORD!
    4- NOW, on the left pane (the menu to the left of the screen, remember?), go into "Advanced Wireless Settings". See that button that reads "Setup Access List"? Click on it! :p
    5- Once in, DISABLE "Turn Access Control On". In other words, uncheck it.
    6- Apply Changes, and for God sakes wait for it to finish!
    7- On your iPhone, go to "Settings", then "General", scroll down to the end and tap on "Reset". Don't worry. It will not reset your iPhone. It will merely bring a new menu. Now from this menu, tap on "Reset Network Settings". Let the iPhone throw its fit... it's OK!
    8- Try to log into your WiFi network using the password you were supposed to have written down in step 3 above.
    9- You should be able to connect now to your protected network with full strength and all!
    ENJOY!
    I hope this helps you as it did me...
     

Share This Page