iPhone 2G + 3.0 + Cingular Blue

Discussion in 'iPhone' started by mak10, Jun 17, 2009.

  1. mak10 macrumors regular

    Joined:
    Feb 6, 2009
    #1
    Just in case there are still people out there that have Cingular Blue aka AT&T Wireless from before the Cingular merger, if you update your unlocked iPhone 2G to 3.0, it breaks the EDGE network. Everything else works fine (minus youtube like others complained about) over wifi, but you can't get on the EDGE network (or at least I can't). When I first got the iPhone 2 years ago, I had to edit a plist file to change the network settings to allow the phone to get on the EDGE network, and now since I can't get into the file system (since the jailbreak hasn't been released) I can't edit that file to even try to enable the network with the old mMode settings. Good news though, the unlock is maintained and if I really wanted to for the next day and a half while I wait for my iPhone 3G S (and finally migrate to AT&T) I can easily downgrade since the baseband isn't touched with the 3.0 update.

    Only thing I didn't do when updating was update the carrier file that iTunes asked me to do, so I don't know if that would have helped the issue...
     
  2. mak10 thread starter macrumors regular

    Joined:
    Feb 6, 2009
    #2
    For those that care:

    I figured out how to get the EDGE network back up and running on my unlocked 1st Gen unlocked iPhone running 3.0 os using a AT&T Wireless aka Cingular Blue Sim. I was able to update a carrier file that was supposed to unlock tethering on the 3G iPhone and change the apn settings to the cingular blue settings I used on a plist file before, then just emailed myself the file, clicked it on the iPhone (using wifi of course) and then installed it, and BAM! EDGE network works perfectly again. Still doesn't fix youtube though, that's another issue.

    basically all i had to change was the "wap.cingular" to "proxy" and it works...
     

Share This Page