Iphone 2g 3.1.2 NO WIFI Problem -HELP-

a1rjumpman23

macrumors member
Original poster
Jul 15, 2008
75
0
So i just recently updated my iphone 2g that was on 2.2.1 to 3.0 then to 3.1.2. I unlocked it with red snow at 3.0 then upgraded to 3.1.2 and used blackra1n but for some strange reason the iphone is unlocked but it doesnt detect any wifi at all. I tryed resting the network and erase all data, but still nothing. I even tryed to restore back to 3.1.2 and it still doesnt work. Can someone please help me with this because im totally freaking out
 

mccb

macrumors newbie
Dec 15, 2009
1
0
Crazy but true

I had no problems until I updated to 3.1.2 then the wifi connection slowly got worse until it could not detect any networks. I tried all the suggested fixes such as restores, reset network settings ect nothing worked, man I was crazy and willing to try anything. So I discovered on you tube the method of cooling the phone, so I used the drastic method of putting the iphone in the freezer.Yes it works, but only until the iphone warms up then the wifi is lost again. But it works every time. I do have to really make the iphone cold, switch off and leave for about 30 minutes. So I would suggest that this is a hardware problem or maybe a software problem that causes the chip to overheat.
If at first it does not work then leave the iphone a little longer in the freezer.
 

-aggie-

macrumors P6
Jun 19, 2009
16,800
50
Where bunnies are welcome.
maybe a software problem that causes the chip to overheat.
If at first it does not work then leave the iphone a little longer in the freezer.
as you said this is only a temporary fix. I had the same issue and the freezer trick works, but only until the chip overheats.

I took mine to the apple store and they replaced it with no hassles.
 

animate147

macrumors newbie
Feb 15, 2010
2
0
wifi problems on 3.0-3.1.2

For those of you having problems with wifi on 3.0 firmware (notably 3.1.2).
My wifi became unusable after upgrading to the above firmware, my iphone still had a wifi address and the wifi in <settings> was NOT greyed out.

When you do manage to see your wifi for a moment lol

click on the little blue arrow to the right of your host name

change dhcp to static and enter the required info

this worked for me, good luck

P.S. wifi still seems a little weak in comparison to before the upgrade but it is
a vast improvement

iphone 2G fw 3.1.2 baseband 4.5.4_G jailbroken and unlocked
 

animate147

macrumors newbie
Feb 15, 2010
2
0
wifi problems on 3.0-3.1.2

duh, switching to a static ip did actually work for around 5 hours but now its back to :
'cannot join' or 'cannot search' grrrrrrrrrrrrrrrr

why are apple not issuing a statement about this
if it was down to the jailbreak software then you could understand them laughing at us, but it affects un-jailbroken phones just the same
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.