iPhone 2G > 3GS SIM issue

Discussion in 'iPhone Tips, Help and Troubleshooting' started by RainForRent, Dec 22, 2009.

  1. RainForRent macrumors 6502

    RainForRent

    Joined:
    May 31, 2006
    Location:
    Greenville, SC
    #1
    I've been scouring the web and have not found quite the right answer or style of answer I am looking for. I don't want to unlock or jailbreak, I want to stay stock for now. So, my question:

    I had an iPhone 2G. I recently bought a 3GS. It had a SIM card in it, but I didn't think about it and put in my 2G's SIM. I recently noticed that MMS is not functioning for me, but 3G service is. So my question is this:

    1) is it possible to activate the newer SIM? Inserting it doesn't offer an activate screen in iTunes, all I get is no bars up top on the screen.

    2) is there any validity to the fact that MMS isn't working because I have the old SIM? On my bill, they still have me on the 2G iPhone plan– unlimited internet with 200 messages. Could that be it?

    I know for certain that there are plenty of people around here with muuuuch more knowledge than me, and I want to tap that knowledge. Thanks guys!
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
  3. RainForRent thread starter macrumors 6502

    RainForRent

    Joined:
    May 31, 2006
    Location:
    Greenville, SC
    #3
    AT&T 5.6.

    What should it be?
     
  4. Jeffrosproto macrumors 6502

    Joined:
    Jun 10, 2008
    #4
    IIRC, you have to have the iPhone 3G/3GS plan for MMS to be enabled on your account. If you currently have 200 SMS, the comparable 3G plan is $15 more. I'm sure AT&T would be more than happy to upgrade you if you call them. You are really lucky to be keeping that 2G plan on your 3GS, in fact they may change it automatically in the future.
     
  5. RainForRent thread starter macrumors 6502

    RainForRent

    Joined:
    May 31, 2006
    Location:
    Greenville, SC
    #5
    So its the plan, not the SIM, huh? Interesting. I don't use MMS often, but I was really looking forward to not having to write down that login crap just to see a picture anymore. I'm curious if it didn't automatically switch because I used my 2G's SIM card? I never had to register/activate the phone when I received it from AT&T, but I assumed that it was just because I bought it as an upgrade phone, and they already had all of my info on file. I just plugged it in and restored from my previous backup.
     
  6. SpaceKitty macrumors 68040

    SpaceKitty

    Joined:
    Nov 9, 2008
    Location:
    Fort Collins Colorado
    #6
    This only applied to 2G iPhone accounts activated prior to September 25 when MMS was enabled. 2G accounts activated after September 25, don't have this MMS block on accounts.

    I activated my 2G on the 450/200 SMS plan last night and immediately placed the sim in my 3G. I was able to send an MMS to my 3GS iPhone with no problems.
     
  7. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #7
    That's the right one. You may have to call AT&T to get it fixed. However, you could try a reboot, resetting network settings, and a restore in DFU mode, in that order, to see if anything fixes it before you call.
     
  8. RainForRent thread starter macrumors 6502

    RainForRent

    Joined:
    May 31, 2006
    Location:
    Greenville, SC
    #8
    I will definitely give that a try tonight, I've got a 12 hour drive today.

    I setup that 2G roughly a year and a half ago, so it was definitely before MMS was enabled. Hmmm.
     
  9. SpaceKitty macrumors 68040

    SpaceKitty

    Joined:
    Nov 9, 2008
    Location:
    Fort Collins Colorado
    #9
    I put that out there just in case.
     
  10. RainForRent thread starter macrumors 6502

    RainForRent

    Joined:
    May 31, 2006
    Location:
    Greenville, SC
    #10
    Everything short of DFU restore and calling AT&T to have them update plan has been done, no changes. I guess this narrows it down a little, I guess it probably is the fact that the phone is showing up to ATT as a 2G. Gotta call and have that activated. But for today, it's family, food and presents. Merry Christmas everyone!
     

Share This Page