iPhone 2G can't negotiate wifi connection?!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by joedornan, Feb 23, 2010.

  1. joedornan macrumors newbie

    Joined:
    Sep 13, 2007
    #1
    Hello all,

    Been searching but haven't found this condition described elsewhere.

    Problem: iPhone 2G (hacked with PwnageTool to 3.1.2) can't negotiate WiFi connections.

    Detail: Recently (can't recall what might have caused this) my iPhone stopped connecting to WiFi. I can see the networks listed, I can initiate a connection, the bars appear at the top of the screen but then disappear. Three times, then no further attempts to connect.

    To diagnose I go into settings>wifi select the network to join, then click the arrow to see details of the wifi connection. I can see the DHCP info come up briefly (for a second or two) and then disappear. Three times. Then it stops trying.

    To further diagnose I go into my Airport Express router's Advanced>logs and statistics>wireless clients window to see what the router sees. When I try to connect from the iPhone it pops up in this list as trying to negotiate at a rate of 54, then 12, then 1, then it disappears off the list.

    Two other iPhones successfully connect to this home network (a 3G and a 2G which is also pwned to 3.1.2).

    The problem iPhone also fails to connect to my WiFi at work. So I know the problem is with the phone not the router.

    These attempts to solve the problem have not worked:

    1) forget this network then reconnect
    2) reboot the router
    3) renew DHCP in iphone>settings>wifi>networkname
    4) reboot the iphone
    5) iphone>settings>general>reset>reset network settings
    6) restore the iphone (using the same custom ipsw created by PwnageTool)
    7) tearing my hair out

    Thanks for your advice! Hope someone here has the time to lend a hand.

    Ciao,
    Joe
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    It might be a hardware issue with your iphones wifi chip.
     
  3. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #3
    To verify it's a hardware issue, stick it in two ziplock bags and put it in thefreezer for 10 minutes. If it then works for awhile, it's definitely hadware.
     
  4. joedornan thread starter macrumors newbie

    Joined:
    Sep 13, 2007
    #4
    -aggie-:

    When I read your post I thought you were either crazy or joking and ignored it! :-O

    After much additional wasted time searching I found a detailed explanation which led me to the same conclusion:

    http://www.hackint0sh.org/f127/62939.htm

    serves me right! (though you might have explained *why* I should put my phone next to my vanilla ice cream :)

    Leaving my phone next to an open window for 30 minutes (its winter here) 'solved' the problem. Now the question is... what do I do about it!

    Thanks guys!

    -Joe
     

Share This Page