iPhone 2G; Froze during jailbreak, and no USB Drivers?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by akaktsn, Dec 4, 2010.

  1. akaktsn macrumors newbie

    Joined:
    Dec 4, 2010
    #1
    Hi, I recently received an iPhone 2G from my cousin who thought they broke it. He had erased all contents and settings. This was not a problem because I simply put the phone in DFU mode and then restored it and updated it using itunes. Well...I had this old blackra1n sitting on my desktop and I knew it would not work but I was just curious so I ran it and it detected the device and halfway through it froze. I did not think this was a problem because I assumed I would be able to put it in DFU mode again and restore it. This has not been the case. I can get it into DFU mode but no computer will recognize the iPhone through USB.

    Now I have tried the following:

    Different USB Cables
    Going through a USB HUB
    Reinstalling Itunes( I am currently running OS X 10.6.3 and Itunes 10.1)

    I believe the USB drivers are corrupt on the iPhone itself and if anyone can tell me how to reinstall them( I'm guessing without using the USB ) that would be fantastic. I believe this is possible because "Moi un Mouton" mentioned it in the thread:

    http://forums.macrumors.com/showthread.php?t=850581


    So any suggestions would be very helpful. Thank you all for your time.
     
  2. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #2
    You have a slight misconception from the linked thread. The different drivers are on the computer and not the phone.

    Have you tried using a different computer? Or a different user profile on yours?

    I would personally try a windows machine as well.
     
  3. akaktsn thread starter macrumors newbie

    Joined:
    Dec 4, 2010
    #3
    I have tried different computers. I just actually tried a windows machine and it is the only thing I have gotten a response from. If that does not work then I will try a different profile on the mac. Thanks for the reply.
     
  4. akaktsn thread starter macrumors newbie

    Joined:
    Dec 4, 2010
    #4
    Ok so I have tried the windows machine and it basically tells me that the device has malfunctioned. Other iphones work on the same machine. Is there seriously not a way to install drivers to this iphone? I mean I will literally at this point take it apart and install them directly onto the logic board(if thats possible). Using a different profile on the macbook also does not work. This seems to confirm my original hypothesis that the usb driver itself on the phone is corrupted. How does one repair that?
     
  5. CZK macrumors 6502a

    Joined:
    Oct 25, 2010
    #5
    The 30 pin connector may be the cause ( partially broken) OR your usb cable ( i had a genuine usb cable that was broken and this is not visible and when i was trying to restore or put music it was giving error messages during adding process. As soon as i used another cable it worked). There is no USB driver or w/e onto the iphone.
     
  6. gngan, Dec 4, 2010
    Last edited: Dec 5, 2010

    gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #6
    Didn't the OP said he used a different USB cable?

    Why are you repeating what he said?

    OP: You may want to try ifixit.com and see if it's possible to swap out the pin connector on the iPhone. iPhone needs no driver on window or mac.
     
  7. akaktsn thread starter macrumors newbie

    Joined:
    Dec 4, 2010
    #7
    Thanks for all the replies guys.

    gngan, I will look into it. It really bothers me though because I just think that would be too big of a coincidence that the exact same time I try to jailbreak and it freezes that my USB pin connector breaks. I will look into it though because I am desperate. Thanks
     
  8. akaktsn thread starter macrumors newbie

    Joined:
    Dec 4, 2010
    #8
    Through a really dirty internet tangent I think i might have found the problem. I have one question though. When I updated my iphone with itunes the first time. This is a 2g mind you, what version of the iphone os did it use? Does the 2G get 4.1 as well?

    [Edit]: Nevermind it seems 3.1.3 is the most up to date that it gets.
     

Share This Page