iPhone (2g) is conected to WiFi but uses Edge instead, why ?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cudo, Jan 27, 2009.

  1. cudo macrumors regular

    Joined:
    Dec 6, 2007
    Location:
    w bloku
    #1
    hi, my iphone 2g in settings shows its connected to my wifi but uses edge/gsm network instead, why is that ? wifif is ok cos there are 3 computers on this network and all work flawlessly.

    any help appreciated, thx !
     
  2. DPA macrumors 65816

    DPA

    #2
    Does it show the WiFi image in the status bar next to your service provider's name? Sometimes it takes a little bit to connect to the network so give it a little time (like 2 minutes). By then, if it hasn't connected, then post here for further help.

    David
     
  3. cudo thread starter macrumors regular

    Joined:
    Dec 6, 2007
    Location:
    w bloku
    #3
    nope it does not show ifif image in the staus bar, only when i go into settings. it shows my router name and status connected. it never connects to wifi and seems as it is using edge/gsm cos connection is soooo slow ! is there a fix to it? kinda wifi activator ?
     
  4. DPA macrumors 65816

    DPA

    #4
    I also sometimes do not get connected to WiFi networks. If you can, try to go some place like Starbucks, McDonalds or Panera Bread where they offer free WiFi. I know that it is the same kind of WiFi connection at all of those places and my iPhone connects to those networks fine. You may just not be able to connect to the WiFi network that you are trying to connect to. I have had this happen to me. If you can get connected at the places I've recommended, then there is not a problem with your device.

    David
     
  5. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #5
    Would I be correct in assuming that your phone isn't getting an IP address assigned by the router? If so, the issue lies with your router/switch/AP.
     
  6. rdntsher macrumors newbie

    Joined:
    Feb 3, 2009
    #6
    My 2G phone has the same problem. I went into setting, click on blue arrow for network settings, under DHCP scroll down and click renew lease. Then back out and give it a minute. This fixed my wifi connection problem, for now.
     
  7. DPA macrumors 65816

    DPA

    #7
    If you have any more problems, just post here and other posters and myself will do our best to fix it.

    David
     
  8. phredo macrumors newbie

    Joined:
    Aug 15, 2008
    #8
    The Same Problem

    I found this thread via a google-search because i have the exact same problem.

    My iphone 3G suddenly started behaving like described above;

    WiFi connects and i check that i have an ip-adress. After maybe 2 minutes the wifi-symbol occurs and i open eg. the app store or safari. Then the symbol immediately changes back to Edge which is confirmed by the app store prompt "you must be connected to wifi to download this 10MB+ file".

    This has never before been a problem and it started happening yesterday. I double checked with my colleague's iphone which perfectly and immediately connects and uses the same wifi network.

    Any ideas? could hardware be broken?

    Thank you in advance!
     
  9. phredo macrumors newbie

    Joined:
    Aug 15, 2008
    #9
    The Same Problem: Additional Info

    Just found out that if i turn on Airplane Mode and then connect the wifi it works.

    This is of course not optimal as i can't accept or make calls during wifi-access.

    Any sollutions om how to get the wifi to work as it's supposed to? As mentioned it suddenly started acting strange.
     
  10. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #10
    First try resetting the phone and see if that fixes it.

    If it doesn't, try restoring the phone and that should fix it.
     

Share This Page