iPhone 2G - Not Responsive

Discussion in 'iPhone Tips, Help and Troubleshooting' started by pelicanflip, Jul 31, 2009.

  1. pelicanflip macrumors 6502a

    Joined:
    Jun 24, 2009
    Location:
    NYC
    #1
    Okay, so I've had my iPhone 2G for quite some time now, it's ages beyond ages old. The water sensors have never been tripped, I've never spilled water on it, there are no cracks/scratches on the screen itself, just minor damage on the bezel and back. It is/was an iPhone 2G, running on 2.2.1, jailbroken and unlocked on T-Mobile. The warranty is most definitely over.

    I dropped my iPhone about two weeks ago onto the floor, and everything seemed to be fine, all the apps were working. It landed on to the upper right corner of the bezel, right below and to the side of the power button, and it caused some minor scuffs. My iPhone started having problems about 45 minutes ago.

    I was about to go to sleep, so I decided to charge my iPhone after a long day of usage, seeing as how I have about 30% left of the battery.



    When I plug it into the USB charger, I realized that it was not responding to the charger. I tried plugging it into several different sockets; same results. I took a look at my charger, and realized that the panels that hold together the charger were cracking. I disconnected the charger from my iPhone, and in the process, the panels promptly fell off and the clicky release buttons on the side fell out too. Therefore, I tried using my spare charger; same results, no charge.

    Next, I tried plugging it into my computer, but iTunes does not recognize my iPhone. I tried plugging it into my laptop, and yet again, iTunes does not recognize my iPhone.

    I attempted to do a DFU restore. I opened iTunes, pressed the Home and Sleep/Wake button at the same time, and waited ten seconds (I used a digital timer to be literally exact). After I waited, I released the Sleep/Wake button and waited another ten seconds. No response from my iTunes. I tried it an additional four times. Tries 2 and 3 consisted of accurate 10 second intervals, tries 4 and 5 I extended holding the Home button after releasing the Sleep/Wake button. No such luck.



    If I shut off my iPhone and plug it into my laptop/computer/random socket via the USB charger, my iPhone goes to the Apple logo, and then powers up. Obviously, there's a connection through the cord, but there's no charge going through...

    If I attempt to do DFU restore, my iPhone obviously shuts down as part of the process, but requires several Sleep/Wake + Home button tries in order to turn it back on, or I have to use the USB charger.




    Any ideas on how the heck I can possibly salvage this? My head's spinning from tinkering with my iPhone. I can't tell if it was the charger's fault, my fault from dropping the iPhone (dropped from a height of maybe 1 - 2 feet off the ground), or if the battery is finally going RIP.

    Or should I just give the hell up, see what a Genius can do for me? Or upgrade to a 3G or a 3GS? I can't really afford signing up with AT&T, so all help is appreciated.

    Cheers and thanks,

    :apple:Dustin
     
  2. pelicanflip thread starter macrumors 6502a

    Joined:
    Jun 24, 2009
    Location:
    NYC
    #2
    New update on the iPhone 2G.

    Basically, my iPhone started to try to restore itself over and over again, to the point where it drained its batteries completely.

    I talked to a total of six different Geniuses at three different Apple stores (Roosevelt Field Mall, SoHo, and 5th Avenue). All six Geniuses were completely baffled by my iPhone, their Macbook Airs did not recognize my iPhone at all, and they came to the same conclusion that I did.

    All in all, it's going to cost me $199 plus tax to replace my iPhone.


    Now, the question is, is there any way I could upgrade to a 2G 16 GB iPhone?
     

Share This Page