iphone 2G running horribly slow after 3.0 update

Discussion in 'iPhone' started by melissarae, Jul 19, 2009.

  1. melissarae macrumors regular

    melissarae

    Joined:
    May 2, 2008
    Location:
    tampa, florida
    #1
    ever since we updated our iphone 2g jailbroke and running on tmobile and upgraded to 3.0... our iphones are running like crap :mad: it takes forever for a the SMS app to load and freezes up every now and then on incoming calls and has just been really horrible ever since we upgraded to 3.0. has anyone else experienced this? is there a way to downgrade them back to the latest 2.0 firmware? any suggestions on what to do here?

    advice is much appreciated.
     
  2. fishmoose macrumors 68000

    Joined:
    Jul 1, 2008
    Location:
    Sweden
    #2
    You could always try a restore but then you need to JB again, you can downgrade to 2.2.1 but I'm not sure how you do it (has been posted here somewhere)

    Or wait for 3.1 and hope that fixes it.
     
  3. enoC macrumors 6502

    enoC

    Joined:
    Jul 2, 2009
    Location:
    Denmark
    #3
    Have you tried restoring as a new iPhone? Before you do this, make sure that you have synced everything with iTunes.
     
  4. ct2k7 macrumors 603

    ct2k7

    Joined:
    Aug 29, 2008
    Location:
    London or Florida
    #4
    This usually clears it up, but, you'll need to setup as a new phone, not restore from backup :)
     
  5. bmcgrath macrumors 65816

    bmcgrath

    Joined:
    Oct 5, 2006
    Location:
    London, United Kingdom
    #5
    Restoring doesn't help. It's just the 2G and V3 on the software don't play nice. Mine has been running like a dog ever since I updated. Think I might drop some AU$ on a unlocked 3GS for speeeeeeeeed
     

Share This Page