iPhone 2g unlocked gets error

Discussion in 'iPhone Tips, Help and Troubleshooting' started by akfsx, Oct 13, 2013.

  1. akfsx, Oct 13, 2013
    Last edited: Oct 13, 2013

    akfsx macrumors newbie

    Joined:
    Oct 13, 2013
    #1
    I updated my iPhone 2g unlocked to iOS 3 and i got this error: The SIM card inserted in this iPhone does not appear to be supported. I am not really sure why I am getting this error as when it was running iOS 1 or 2 it was working perfectly with the carrier UNITEL but now it only works with Vodafone which there is no serice where I live.
    Can someone please help me.

    Thanks
     
  2. TribeFan1 macrumors regular

    TribeFan1

    Joined:
    Oct 1, 2013
    #2
    When you update a non factory unlocked iphone like the one you have it eliminates the 3rd party unlock. You'll have to unlock it again
     
  3. akfsx thread starter macrumors newbie

    Joined:
    Oct 13, 2013
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    You need a very old version redsnow.
    Its a long process so if you're not comfortable I wouldn't attempt it.
     
  5. akfsx thread starter macrumors newbie

    Joined:
    Oct 13, 2013
    #5
    Will whited00r do the trick? Like getting whited00r unlocked. Or can you guide me through the redsn0w process.
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Whitedoor has nothing to do with the unlock.
    Its a completely different thing for a different purpose.
     
  7. akfsx thread starter macrumors newbie

    Joined:
    Oct 13, 2013
    #7
    Oh ok. Can you help me using the old redsn0w version to reunlock my iPhone I guess. For some reason it works with Vodafone and maybe other carriers but not Unitel. Because I have another iPhone 4 factory unlocked like the 2g but it's running iOS 7 with Unitel. Maybe there is something to do with the iOS version.
     
  8. akfsx thread starter macrumors newbie

    Joined:
    Oct 13, 2013
    #9
    I'm getting errors while trying to download redsn0w, BL 3.9 and BL 4.6
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10

Share This Page