iPhone + 2WIRE 2701 DNS problem?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by The General, Jul 5, 2007.

  1. The General macrumors 601

    Joined:
    Jul 7, 2006
    #1
    I am having trouble getting my iPhone to work on wi-fi here in the office. We have AT&T Yahoo! DSL and they gave us a 2WIRE 2701 modem/wireless router ... I don't know if it just hates Apple and Macs, but I've always had trouble getting Macs to work with this router. I have to run the network setup assisstant in order to get it to work right, otherwise it will be "connected" to the router but it won't be connected to the Internet. Haha, the iPhone automatcally capitalizes Internet.

    Anyway, I'm having the same problem with my iPhone. It will connect initially, but when I try to use Safari or a widget, it switches back to EDGE. I think it might by that DNS bug, bug honestly I don't know that much about networking. I found a list of DNS addresses on Google, and tried the 4 listed for at&t but none of them worked. I'm also not even sure if when I type the address into the DNS field, its even taking effect. :eek:

    I know it's not the iPhone though, since wifi works great elsewhere. It's got to be the router or the ISP.
     
  2. ctapia macrumors newbie

    Joined:
    Jul 4, 2007
    #2

    Sorry not much help to your problem, but I'm also on AT&T Yahoo DSL account with 2Wire modem/wireless router and have the same problem. My iphone detect the wireless network, I go an enter the WEP key but they "lock" icon does not go away, meaning that I still don't have access to it. Can you please verify on your iphone if the lock symbol shows next to your wireless network.
    As side note, my laptop connects wirelessly to it, no problem so my WEP key is correct.
     
  3. The General thread starter macrumors 601

    Joined:
    Jul 7, 2006
    #3
    As far as i know, the lock icon just means that it is a secured network. The radio wave airport symbol shows on the top left which means its connected.
     
  4. ctapia macrumors newbie

    Joined:
    Jul 4, 2007
    #4

    Yes, it means that it's a secured network, but once you've entered the correct key, the lock should go away. Or at least that's what I'm seeing here.

    http://www.macrumors.com/iphone/2007/06/30/unable-to-access-password-wifi-networks/

    I'll poke around some more tonight and see if I get my home network to connect.
     
  5. The General thread starter macrumors 601

    Joined:
    Jul 7, 2006
    #5
    That's weird, man. Here at home on my 802.11n Airport Extreme, the lock remains there when I am connected. :confused:

    [​IMG]
     
  6. ctapia macrumors newbie

    Joined:
    Jul 4, 2007
    #6

    Thanks for the pic... Last night I tried switching the WEP key to hex format and bam, I connected. The key lock went away and connected to my wireless network. I swear I had tried this the night before with no luck.

    Later in the night, I went back to the Wi-Fi Settings and saw the the lock symbol was back on, however I was still connecting to it. So, this jives with what you're saying. So are you able to get on wifi now? I'll see how it goes tonight went I get home and try to connect to it again.
     
  7. osfoz macrumors newbie

    Joined:
    Feb 18, 2009
    #7
    my solution: use the 10-digit numeric password on the modem

    I had this exact same frustrating problem. The problem was a simple password issue. Although I had changed the password on the modem to my own personal one, that password only affected the administrator settings. When I used this particular password on my iphone it would put the checkmark next to the 2wire, but I would not get the wifi symbol at the top of the screen.

    I fixed the problem by using the 10-digit password supplied on the actual router instead. I told my iphone to 'forget' the network, then reselected it and when it requested my password I typed in the 10 digit number and 'presto,' i had wifi symbology!

    I hope this helps.
     

Share This Page