iPhone 3.0.1 Jailbreak on 2G iPhone

Discussion in 'Jailbreaks and iOS Hacks' started by danieljacobj, Jul 31, 2009.

  1. danieljacobj macrumors newbie

    Joined:
    Jun 10, 2009
    #1
    Has anyone had any luck using redsn0w 0.8 to jailbreak after updating to 3.0.1 on an original iPhone? I was able to update and redo the jailbreak on my 3GS but can't seem to get it to work on my 2G. I seem to get stuck after I hold the power and home buttons down, it never powers back on and redsn0w says "waiting for device to reboot" or something like that. I am open to any suggestions. Thank you
     
  2. Dakenson macrumors newbie

    Joined:
    May 6, 2009
    Location:
    Mexico City
    #2


    exactly the same problem here... No rebooting even redsn0w says it's waiting for it :confused: I had 3.0, updated to 3.0.1 and then tried to jailbreak 3.0 again but it doesn't work, I was planning to use Pwnage Tool but I still have Pwng Tool 3.0 and I can't find the bug-fixed 3.0.1
    Where can I get it?
     
  3. iLeoMarc macrumors regular

    Joined:
    Jul 22, 2007
    #3
    When stuck at "waiting for reboot" just unplug the iPhone from the USB and reconnect. Should recognize it as rebooting :)
     
  4. mikehockenballs macrumors member

    mikehockenballs

    Joined:
    Nov 6, 2007
    Location:
    Greater Manchester, England
    #4

    After a few attempts I have successfully used redsnow 0.8 which is now available on the Dev Team site and have upgraded to 3.01. It took me a few restores and in total I have ran redsnow 4 times to get to the correct state. I found that if I selected 'icy' to be used by redsnow that it would crash redsnow, so I had to untick the box. At one point the only icon I had on my phone was the cydia one and nothing else, but I just kept perservering until it worked completely.

    So dont give up easily keep trying redsnow.
     
  5. slu macrumors 68000

    slu

    Joined:
    Sep 15, 2004
    Location:
    Buffalo
    #5
    This is what worked for me.
     
  6. danieljacobj thread starter macrumors newbie

    Joined:
    Jun 10, 2009
    #6
    Unplugging the phone and reconnecting helped fix mine. I guess I was thinking it would be more like doing my 3GS where I didn't have to do much at all. Thanks again for the help.
     
  7. RobT macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    Location:
    Ohio, USA
    #7
    Thanks, that's awesome! I was stuck at waiting to reboot too and your advice was perfect!
     
  8. mokum macrumors newbie

    Joined:
    Aug 3, 2009
    #8
    How can I thank you enough? I tried everything for 24 hours, all hits I got at google, all tips, all tricks: nothing worked... but unplugging.

    Thank you a LOT for this trick, it saved me from having to fight with my wive over the 3rd and last working iPhone ;)
     

Share This Page