iPhone 3.0 GM and BossPrefs hidden icons

Discussion in 'Jailbreaks and iOS Hacks' started by Ekim Neems, Jun 9, 2009.

  1. Ekim Neems macrumors member

    Joined:
    Aug 23, 2007
    #1
    Hey all,

    I unintentionally upgraded to iTunes 8.2 last week, so when I heard 3.0 GM was good to go (no dev account needed) I figured I'd give up jailbreaking for awhile and try it out.

    Unfortunately, my Settings icon is hidden. I didn't even have this hidden with BossPrefs which is the truly strange thing. But it appears I have no way to get it back.

    Anything I can do to fix this? Thanks!
     
  2. LSUtigers03 macrumors 68020

    LSUtigers03

    Joined:
    Apr 9, 2008
    #2
    You can try a dfu restore and set the phone up as a new phone.
     
  3. DravenGSX macrumors 6502a

    Joined:
    Aug 20, 2008
    #3
    DFU restore to 2.2.1. Download an older version of iTunes and re-jailbreak. Install Boss Prefs, unhide everything (categories and SBSettings also if you installed them), then install iTunes 8.2 and re-flash with 3.0GM.
     
  4. Polymira macrumors regular

    Joined:
    Feb 1, 2008
    #4
    Why on earth would he need to downgrade, jailbreak, etc?

    A full restore in dfu mode will format the partition with all of the iPhone software then re-install. That's all you need.
     
  5. monkeyvp macrumors newbie

    Joined:
    Jun 30, 2009
    #5
    i have a similiar problem, but I think its worse.

    I have hidden my settings and my cydia icons, and when I upgraded to 3.0 they are both hidden. I know I need to get into settings but I dont know how... I cant install app flow because I dont have cydia.

    I do have icy but there doesnt seem to be any decent app launcher apps on there? I have tried to instal Dock but it doesnt seem to work for some reason.

    anyone have any ideas how I can launch settings? i dont want to restore to default because I have lots of texts I wanna keep...

    Any help would b great, thanks!
     
  6. poolish macrumors regular

    Joined:
    Jul 23, 2007
    Location:
    south coast, uk
    #6
    if you can find something like bossprefs, sbsettings, or poof, then you could unhide the icons. or maybe you could install open ssh with icy? then copy your files like the sms.db and call history etc to your mac then copy them back after a restore.

    if you have ssh access, navigate to the cydia.app/settings.app and inside should be a file called Info.plist, open this and find the variable called SBIsRevealable and it should be true, so change it to false. then save, and you will prob have to respring.
     
  7. FreakinSyco macrumors regular

    FreakinSyco

    Joined:
    May 3, 2007
    #7
    I had this same issue. The fix has been posted on here before:

    Just go into Settings > General > Restrictions > and enable, then disable restrictions. Then restart your phone. All icons will appear as normal.
     
  8. superxero3 macrumors regular

    Joined:
    Oct 15, 2008
    #8
    This works, i don't think you even need to reboot your phone, but it couldn't hurt. IF you have cydia installed and need to get into it, but it is poofed, open up safari and type in this URL: "cydia://" (you might need to capitalize the C in Cydia) and cydia should pop right open.. that's a little trick i found out when i was in the same boat as you.
     
  9. dropknee1 macrumors newbie

    Joined:
    Jan 21, 2010
    #9
    its funny..i tried the settings, restrictions trick

    and it didnt work..i tried reinstalling and that didnt work..after i reinstalled and did the settings trick one last time..it still didnt work..so i just slid to the search iphone page and typed in poof. it opened and i made my apps visible.
    much much easier. and makes the most sense.. lol:D
     

Share This Page