iPhone 3.0 - No WiFi.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Coops46, Sep 5, 2009.

  1. Coops46 macrumors member

    Joined:
    Aug 8, 2006
    #1
    So, ever since I upgraded my 3G to 3.0 I've literally had no wifi, nothing comes up in the wifi menu and I've tried everything that has been said about the issue. I've reset network settings etc and still nothing, most people's phones can at least see networks, but I'm yet to.

    The phone's now out of warranty so not really sure what to do...

    Thanks for any help.
     
  2. RobMoss macrumors regular

    Joined:
    Jul 23, 2009
    #2
    Why did you leave it until it was out of warranty before doing anything about it..?
     
  3. fireshot91 macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
    #3
    Did you try a restore back to factory defaults?

    Did you try to downgrade to 2.x?
     
  4. Coops46 thread starter macrumors member

    Joined:
    Aug 8, 2006
    #4
    I was travelling between 3.0 coming out and my warranty finishing, so unfortunately came back, turned it on and upgraded it and now no wifi.

    I've done lots of restores but haven't downgraded, worked fine on 2.x but not sure how to downgrade...
     
  5. nparmelee macrumors 6502

    Joined:
    Jan 23, 2008
    #5
    In this case, if you've looked at the support stuff on the Apple site and still not seeing any WiFi, it might still be worth a trip to the Apple Store and see if they can help.
     
  6. kmbaroyale macrumors newbie

    Joined:
    Sep 6, 2009
    Location:
    Munich, Germany
    #6
    wifi problem on iphone

    Although my G3 iPhone detects a wifi network when I am home, as soon as I go on-line the icon disappears and I am then on the normal cellular provider network. I have been checking forums for weeks now and someone suggested switching off security settings on my router.
    This I did and, hey presto, wifi works perfectly. When I restore the security settings on my router, wifi drops immediately. At least I know that the iPhone is working. I have a Netgear MR814v2 router.
    I hope this also helps someone else
     

Share This Page