iPhone 3.0 Users; Enable Tethering in 1 Minute! NO MMS!

Discussion in 'iPhone' started by dietwater5, Jun 16, 2009.

  1. dietwater5 macrumors newbie

    Joined:
    Jun 26, 2007
    #1
    I have 3.0GM with no hacks or anything done to my OS. My friend posted this on twitter today and I tried it and it worked for me. For those who have 3.0 use this link and it enables it in your settings. You must open the link on your iPhone using Safari. I have a unibody 13" macbook and it paired. If this was posted before sorry.

    http://tr.im/oGhq

    Update title since people kept asking if it enables MMS, NO IT DOES NOT ENABLE MMS! Only Tethering.
     
  2. The General macrumors 601

    Joined:
    Jul 7, 2006
  3. HarrisonB macrumors 6502

    Joined:
    Jun 16, 2009
    #3
    how do you pair once it's installed?
     
  4. bigscotal macrumors 6502

    bigscotal

    Joined:
    Jun 26, 2008
    Location:
    UK
    #4
  5. deimos256 macrumors 6502a

    Joined:
    Sep 9, 2008
    #5
    go into settings -> network, and there should be an option for tethering, worked for me although i didnt test it, just can confirm it unlocks the setting and i can indeed turn it on im on AT&T, too bad that website doesnt have an MMS profile for AT&T
     
  6. Incindium macrumors member

    Joined:
    Apr 3, 2009
    #6
    Here is what is actually downloaded for US-ATT:
    A file named

    us_att.mobileconfig


    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    	<key>PayloadContent</key>
    	<array>
    		<dict>
    			<key>PayloadContent</key>
    			<array>
    				<dict>
    					<key>DefaultsData</key>
    					<dict>
    						<key>apns</key>
    						<array>
    							<dict>
    								<key>apn</key>
    								<string>wap.cingular</string>
    								<key>type-mask</key>
    								<integer>-2</integer>
    								<key>password</key>
    								<data>Q0lOR1VMQVIx</data>
    								<key>username</key>
    								<string>WAP@CINGULARGPRS.COM</string>
    							</dict>
    						</array>
    					</dict>
    					<key>DefaultsDomainName</key>
    					<string>com.apple.managedCarrier</string>
    				</dict>
    			</array>
    			<key>PayloadDescription</key>
    			<string>Provides customization of carrier Access Point Name.</string>
    			<key>PayloadDisplayName</key>
    			<string>Advanced Settings</string>
    			<key>PayloadIdentifier</key>
    			<string>us.att.profile.apn</string>
    			<key>PayloadOrganization</key>
    			<string>AT&T</string>
    			<key>PayloadType</key>
    			<string>com.apple.apn.managed</string>
    			<key>PayloadUUID</key>
    			<string>D39F0171-21ED-4D6D-B951-2F25071EC3A5</string>
    			<key>PayloadVersion</key>
    			<integer>1</integer>
    		</dict>
    	</array>
    	<key>PayloadDescription</key>
    	<string>AT&T US - BenM.at</string>
    	<key>PayloadDisplayName</key>
    	<string>AT&T</string>
    	<key>PayloadIdentifier</key>
    	<string>us.att.profile</string>
    	<key>PayloadOrganization</key>
    	<string>AT&T</string>
    	<key>PayloadType</key>
    	<string>Configuration</string>
    	<key>PayloadUUID</key>
    	<string>BB32FB38-DF65-4CA8-BD29-960AC2E7FDC7</string>
    	<key>PayloadVersion</key>
    	<integer>1</integer>
    </dict>
    </plist>
    
     
  7. TurboSC macrumors 65816

    TurboSC

    Joined:
    Aug 4, 2007
    Location:
    California
    #7
    interesting find, I wonder if this will be patched after 3.0 official release.. I know AT&T is probably running around pulling their hair out.
     
  8. phoenixdude24 macrumors member

    Joined:
    Mar 19, 2009
    #8
    um perhaps im missing something but my 3.0GM on my iphone has tethering by default. I'm US AT&T and haven't changed a single setting on the device network related, nor have i uploaded any hacked .ipcc files. No MMS though...
    [​IMG]
    [​IMG]
     
  9. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #9
    Works like a charm in the San Francisco Bay Area, CA, USA.......:p:p:p:p:p
     
  10. dissdnt macrumors 65816

    dissdnt

    Joined:
    Aug 3, 2007
    #10
    It popped up to install but don't see a tethering setting.

    3.0 GM, first gen iphone. Even did a reboot. Oh well :(

    settings > general > network?
     
  11. UnitedLax342 macrumors member

    Joined:
    Jun 18, 2008
  12. iSimon macrumors regular

    Joined:
    Mar 3, 2008
    Location:
    Glasgow
    #12
    I don't think you can have tethering on first gen iPhone. Could be wrong, but I know here in the UK the O2 site specifically states that "Intenet tethering doesn't work with 2G iPhones". Not sure if that's just down to carrier settings or something actually coded into the OS to prevent tethering on a 2G iPhone.
     
  13. rasher macrumors newbie

    Joined:
    Jun 16, 2009
    #13
    this definitely works...i'm on it now, and it's surprisingly fast

    hook us up with MMS too

    [​IMG]
     
  14. dissdnt macrumors 65816

    dissdnt

    Joined:
    Aug 3, 2007
    #14
    Ahh could be. I'm getting a 3G S⃣ on Friday, i'll give it a try then.
     
  15. Clavius macrumors newbie

    Joined:
    Apr 16, 2009
    #15
    Do you get charged per MB for tethering this way? You might be able to check if you're getting billed on o2.co.uk.
     
  16. Ntombi macrumors 68030

    Ntombi

    Joined:
    Jul 1, 2008
    Location:
    Bostonian exiled in SoCal
    #16
    Worked perfectly for me, thanks! If only they had an mms option for AT&T.
     
  17. bigscotal macrumors 6502

    bigscotal

    Joined:
    Jun 26, 2008
    Location:
    UK
    #17
    That sir, is the million dollar question! :p

    I have confirmed that it works by loading a couple of webpages, but that's it for me just now. Until I see what is going to happen re charging, I won't be using it any more.
     
  18. jman240 macrumors 6502a

    Joined:
    May 26, 2009
    #18
    Anyone email this site about MMS options. It says if your carrier isn't listed to email. I'm on ATT but I don't want to spam the guy for a settings file if someone already has.
     
  19. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #19
    Yup, *looking* for the MMS thread for AT&T......:mad::mad::mad::mad:
     
  20. gottafly macrumors regular

    Joined:
    Aug 26, 2008
    #20
    after the install, "set up internet tethering" appears in Settings/Network, but when I click on it I get "Set up internet tethering. To enable tethering on this account, contact AT&T".

    any thoughts/ideas?
     
  21. deimos256 macrumors 6502a

    Joined:
    Sep 9, 2008
    #21
    i think the guy who did this is on these forums somewhere, i recall in another thread someone asking for feedback and saying he was working on AT&T MMS settings
     
  22. coolwater macrumors 6502a

    coolwater

    Joined:
    Jun 8, 2009
    #22
    I wonder if anybody ever got caught by AT&T for tethering and paid a penalty.
     
  23. fishepa macrumors regular

    Joined:
    Mar 9, 2009
  24. Westin macrumors regular

    Joined:
    Jun 16, 2009

Share This Page