iPhone 3.G Time 2 Minutes Slow "MUST READ"

Discussion in 'iPhone' started by merics, Mar 8, 2009.

  1. merics macrumors member

    Joined:
    Jun 9, 2007
    Location:
    Bahrain
    #1
    With the recent shift of clocks ahead 1 hour, I walked around to all my clocks with iPhone in hand adjusting them all. Went to computer and noticed iPhone was 2 minutes behind iMac time. Logged onto time.gov/com and both sites matched iMac, confirming iPhone 2 minutes slow.

    Did google, forum and apple support searches and found nothing that really addressed/provided fix. But in reading the various sites, some spoke about the carrier providing time when iPhone set to automatic etc. Got me thinking.

    I am currently home and usually use WI-FI when home. So I turned on 3G, turned off WI-FI, and lo and behold, time matched iMac, dead on. So I turned off 3G to allow Edge on, and time dropped 2 minutes behind. Turned on WI-FI, remained 2 minutes behind. Turned 3G back on and iPhone jumped to correct time.

    Now I wonder; Do I have a defective iPhone or is this accepted behavior? Anyone else have similar experience?
     
  2. iFerd macrumors 6502a

    Joined:
    Jul 20, 2007
    #2
    It sounds to me like your wireless router is getting its time from a different server than your computer or iPhone when the phone is on the cellular network. I have an Airport Extreme, which has an option to select a time server in its setup program. The default is time.apple.com, which is the same time server that the Mac is set to poll. My phone on wireless and my computer agree about the time.

    Maybe your ISP is serving the time to your router and they are off?
     
  3. MattZani macrumors 68030

    MattZani

    Joined:
    Apr 20, 2008
    Location:
    UK
    #3
    Its not a big problem, when out, it will be correct, and when indoors, you have other clocks, just remember its 2 minutes slow (2 Minutes fast would have been better, i set my clocks a few minutes fast)
     
  4. merics thread starter macrumors member

    Joined:
    Jun 9, 2007
    Location:
    Bahrain
    #4
    Thanks for that, will check. But the time is also 2 minutes behind when using Edge.
     
  5. mcmanus7 macrumors 6502a

    Joined:
    Oct 30, 2008
    #5
    Go to Settings --> General --> Date & Time...

    is your setting set to Set Automatically?

    If you're really that concerned about it I would do a backup and a restore... see if it's still a issue...
     
  6. efice32 macrumors 6502

    Joined:
    Nov 3, 2008
    Location:
    Music City USA
    #6
    take it off set automatically...problem solved
     
  7. merics thread starter macrumors member

    Joined:
    Jun 9, 2007
    Location:
    Bahrain
    #7
    Doesn't changing from auto to manual defeat the purpose. Why have the auto setting if not functioning properly? Why pay for a product and say, it's ok if this or that doesn't do as should?

    Let me reiterate:
    1. Time is 2 minutes slow using WI-FI.
    2. Time is 2 minutes slow using Edge.
    3. Time is accurate to the second using 3G.
     
  8. skwoytek macrumors 6502a

    Joined:
    Feb 15, 2005
    #8
    The WI-FI should be accurate to the last network you were using. So if you use 3G then go to airplane mode and turn WI-FI back on, set the time to manual and dial in an incorrect time, when you set time back to auto you'll be back at the 3G network time. Do the same procedure with 3G off (on EDGE) and your WI-FI time will set back to EDGE time.

    Either way, it's not the device. It's syncing from the local carrier network information. Mine is different between 3G and EDGE also, but only by a minute. And again, WI-FI varies depending on the last carrier network used.

    If you have a problem... Your carrier is to blame. The device is only pulling the time from a source - garbage in, garbage out.
     

Share This Page