iPhone 3G 2.1 turbo sim not working

Discussion in 'Jailbreaks and iOS Hacks' started by iruleee, Sep 12, 2008.

  1. iruleee macrumors newbie

    Joined:
    Sep 12, 2008
    #1
    my turbo sim is not working after upgrading to 2.1 is this only a problem with my phone or are others having it 2 ???
     
  2. hatedorloved macrumors newbie

    Joined:
    Sep 12, 2008
    #2
    hi im using a yessim and its working fine with 2.1 when i turnt phone on first time couldnt recieve calls on 3g waited 15 mins rebooted and works only no jailbreak yet
     
  3. arfawkes macrumors newbie

    Joined:
    Feb 1, 2009
    Location:
    Cyprus / France
    #3
    iphone turbo card problem

    Hi, I bought a cracked iphone in UK which I was told would 'work' with any provider if I bought a turbo sim card. I found the apprpriate card in Hong Kong, fitted it in the sim case along with a CYTA sim card. Initially it worked OK but as soon as I moved away from home by more tahn a couple of miles it failed with the advice 'No signal'. Everytime I tried gte the iphone to find the service it was unable until I put the CYTA sim into another phone and when the 'different' mobile had connected to the provider, I could then reinsert it into the iphone and it would work again until I moved acouple of miles. On one occasion it allowed me go to the next town and worked there for 2 hours then failed.
    Does anyone have any idea what might be happening? I updated the software (after all these failures), on 30th. Jan 2009, but the failure has remained exactly the same.
     
  4. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #4
    *Sigh* Because your "really high tech piece of equipment" that was sold to you by some idiot was designed for a different firmware/baseband. You went and updated, rendering your pain in the ass modification useless. That, and it's so cheap I'm surprised they don't disintegrate into thin air.

    Next time, use yellowsn0w. It works, and it's free. Just don't update to 2.2.1 unless you know what you're doing... Which by the way you explain/type things, you wont.
     
  5. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #5
    1) Upgrade to 2.2

    2) Install yellowsn0w.

    3) Done.
     

Share This Page