Iphone 3g 3.0 + VPN + Auto-Wifi-Hotspot-Page Problem

Discussion in 'iPhone Tips, Help and Troubleshooting' started by D-Fence, Jun 22, 2009.

  1. D-Fence macrumors newbie

    Joined:
    Nov 11, 2008
    #1
    Hi!

    I got a pretty annoying problem with my 3G 3.0.

    When trying to connect to my Uni wlan (VPN Client needed, no web logon), the "Login" page pops up (showing www.apple.com in header) but it only says "You need a VPN client..." (the default page you see when connecting to my uni wlan.
    Now, here is the main problem: When I close that page, the phone drops the wlan connection, so I can't activate / use the phone's VPN client (as I am not connected to the wlan). And as soon as I connect to the wlan, it automatically opens that page again.....and the cycle begins again.

    Is there a way to disable this "autologin" for some networks or completely?

    As well, looks like the VPN client is now following corporate rules and f.e. not allowing to save your password or shared secret in Ipsec profiles, which is also pretty annoying :(

    Regards,

    D-Fence
     
  2. kkrepp macrumors newbie

    Joined:
    Jun 22, 2009
    #2
    I have got a similar problem here. I usually started my Univ. WLAN by joining the unsecured network followed by starting my VPN profile.

    The automatic WiFi-Login "feature" now prevents me from starting VPN. If I enter my login data, I am successfully authenticated by the remote server and I am able to browse the university home page through the Auto-Login UI. For some reason iPhone OS doesn't recognize this connection. So I can only "Cancel" the Auto-Login window and therefore shut down my WiFi connection.

    This is really annoying, I hope Apple will fix this soon, as I consider it to be a major bug. Is there any workaround for this problem yet?
     
  3. sam-84 macrumors newbie

    Joined:
    Jun 23, 2009
    #3
    I had the same problem with my iPod Touch 2G OS 3.0.
    I downloaded the "Boingo" App from the App store and the popup didn't appear no more.
    Hope this will help you.
    sam
     
  4. melllvar macrumors regular

    Joined:
    Oct 28, 2007
  5. abijnk macrumors 68040

    abijnk

    Joined:
    Oct 15, 2007
    Location:
    Los Angeles, CA
    #5
    Same issue here with university page. I'll post if I find a way around this BS.
     
  6. webdesignr macrumors newbie

    Joined:
    Jun 24, 2009
    Location:
    Verdal, Norway
    #6
    Automatic Wi-Fi Login = Buggy

    I had or possibly still have the same issue, without using VPN.

    Our Wireless LAN at the office allows no security to the router, but opens a gateway page for logging in, very similar to what you guys are experiencing.

    After installing 3.0, I noticed that new window that pops up from within Settings > Wi-Fi. Before I would have to login through Safari.

    This new window crashes and then I get disconnects from the router.

    After a restart, the window didn't crash.

    Weird. I thought it was because of some issues I have been having today with my Bluetooth headset, but after a restart the headset was not connected and the Wi-Fi connected right away. So I tested a few times and Bluetooth on or off, doesn't seem to affect the Wi-Fi.
    Sorry this is not an answer, but could inspire a solution or bug fix...
     
  7. henhowc macrumors regular

    Joined:
    Jun 12, 2007
    Location:
    Los Angeles, CA
    #7
    Same issue here.

    My university has two methods of authenticating, via bluesocket web portal or VPN. However, after the 3.0 update, the auto-login page always pops up after I connect to a wireless AP and the web auth page loads. If you cancel at this point you always get dropped from the AP back to 3G or Edge.

    If I want to use VPN, I end up having to login twice. Once through the web portal and a second time with the Cisco VPN. Its fairly annoying as I always use the latter method.

    Just wanted to add that I don't and do not want to use auto-fill.
     
  8. NetMage macrumors newbie

    Joined:
    Oct 21, 2007
    #8
    I have read a work around is to add the network manually with no security using the Other... option in Settings|Wi-Fi and the logon page will not pop-up.

    Unfortunately, I am trying to get the logon page to automatically come up with my bluesocket network and it is not working :(
     
  9. JFBourne macrumors newbie

    Joined:
    Aug 17, 2009
    #9
    Hey NETMAGE, I try your suggestion but I did not work. I am also experiencing this issue at my college private network. The auto-log in page is annoying and wont let me do anything because at my college you can only login through the vpn if you are using the wireless network: there is no way to log in through my college home page which is the one that always pop up when the auto log in slide up. If any of you guys find or already found a way around, I would like to know please.Well this is my email just in case:

    fabrejeorge@gmail.com
     

Share This Page