iPhone 3G/3GS Sync problems

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Kattle, Dec 23, 2011.

  1. Kattle macrumors newbie

    Joined:
    Dec 23, 2011
    #1
    Hey everyone. After creeping for sometime I have finally created an account and am posting for the first time :)

    Here is my problem:

    I have an iPhone 3G that is very old and beaten. My friend had the iPhone 3GS that experienced the constant 'No Signal' error. He got an iPhone 4S and gave me his old phone. I took out my SIM card, put it into the 3GS, and synced it with my iTunes account. I also experience the 'No Service' problem. I tried restoring it, but it still occurred. I then took out the SIM card and put it back into my iPhone 3G. Then it went haywire. My 3G phone now rarely receives texts. The 3GS receives my texts. So I'm texting with my 3G and receiving with my 3GS. How can I fix this?

    I assume it's because both phones are synced to the same iPhone information from iTunes? Any help would be greatly appreciated. Thanks!
     
  2. Jamkas macrumors member

    Joined:
    Dec 22, 2011
    Location:
    North New Jersey
    #2
    Your problem seems impossible to me.

    Now you say 'texts' does that mean iMessages also or literally just text messages?

    Do both phones have service? Even the one without a SIM card?
     
  3. Kattle thread starter macrumors newbie

    Joined:
    Dec 23, 2011
    #3
    I literally mean text messages. I can send them off my 3G and can sometimes receive them. However, I receive a majority on my 3GS. At the top it says No SIM.
     

Share This Page