iPhone 3g 4.2.1 - can't restore

Discussion in 'Jailbreaks and iOS Hacks' started by smamm, Nov 30, 2011.

  1. smamm macrumors newbie

    Joined:
    Mar 19, 2011
    #1
    I've jailbroken/unlocked a couple of iPhone 3Gs in the past, but have gotten stuck with a phone and can't figure out a fix.

    iPhone 3G
    IOS 4.2.1
    Vista x64

    Was jailbroken/unlocked previously using redsn0w_win_0.9.6rc14. A younger brother then messed with it and got it into a weird state. I have no idea what was done while out of my possession.

    The phone screen only ever displays the apple logo (boot logo) or the picture of a usb cord and the itunes logo. When plugged into iTunes, it prompts me that it's in Recovery mode and needs to be restored.

    I built a custom firmware with sn0wbreeze-2.2.1 and did a Shift\Restore in iTunes. This results in error 1604 and doesn't complete.

    I also tried to restore it via redsn0w_win_0.9.6rc16 with the iPhone1,2_4.2.1_8C148_Restore.ipsw. If I select the "install iPad Baseband" option, redsn0w crashes/disappears during the "fetching iPad baseband files" portion of the process. I edited my hosts file and added this line: 74.208.10.249 gs.apple.com

    If I de-select the "install Baseband" option, I can see redsn0w take over locally on the phone and begin the upgrade process, but it eventually hangs when installing activation bundles and crashes/reboots the phone back into recovery mode. iTunes then continues to prompt that it's in recovery mode and must be restored.

    Any ideas on next steps?

    I don't care what IOS or baseband version it's eventually on, I just want to get it back to a working jailbroken/unlocked state.
     
  2. beechnut macrumors newbie

    Joined:
    Dec 24, 2011
    #2
    I'm having what sounds like nearly the same problem with an iphone 3g and a 3gs. Frustrating and I'm pretty close to just using them as skipping stones on the lake. Tried the redsn0w thing and I think it installed something called cydia??? Anyhow it starts up and it has that pineapple symbol then begins a sort of setup process then blinks out and quits. I;m not real savvy about this stuff and frankly I don't really care to get into it too deep.

    I've seen some online services that offer to remote in to your computer and fix it for you but I'm not sure about letting someone I don't know do that. For example this one:

    http://iphonetounlock.com/index/online_iphone_jailbreak_and_unlock_online_iphone_repair/0-8

    Anyone have any experience with a service like this? Is it legit?

    I'm at the point where I'd like to have someone try to get these working for me, or at least tell me they're toast so I can just dump em and move on.
     
  3. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #3
    make sure you put the phone into DFU mode first, then restore it. It will go through, you can't let it in recovery mode and then restore.
     

Share This Page