iPhone 3G and iOS 4: Long pause before loading Photo and Camera apps

Discussion in 'iPhone Tips, Help and Troubleshooting' started by TheJackal, Jul 4, 2010.

  1. TheJackal macrumors member

    Joined:
    Mar 15, 2008
    #1
    Ever since updating to iOS 4 I've had this weird problem, when launching the "Photos" app there's a 4-5 second pause before I'm able to select an album to view. I can see the list of albums but the status bar (where the time, carrier text, battery info is) is black and will only turn to grey 4-5 seconds later.

    Its also taking 4-5 seconds longer for the Camera app to open the shutter so I'm guessing its related.

    I've compared it to a friend's iPhone 3G also running iOS 4 and his is fine. To add more insult to injury, he's got about 200 more photos than I do so I'm guessing its not the number of photos which is causing this...

    Thoughts?
     
  2. TheJackal thread starter macrumors member

    Joined:
    Mar 15, 2008
    #2
    I've tried a full reset of all settings and its still the same....

    Anyone?
     
  3. openkimono macrumors newbie

    Joined:
    Sep 19, 2008
    #3
    I have the same exact symptoms. Across the board, most applications are either slow to load, or crash unexpectedly, when they ever did with the previous OS. Messages app is slow as well, sometimes taking as long as 10 seconds to load.

    Clearly OS4 was never truly made to support the 3G. It's almost making this phone unusable and I'm considering downgrading the OS.
     
  4. MorganK macrumors regular

    Joined:
    Apr 13, 2010
    Location:
    Mobile, AL
    #4
    I'm having the same issues as both PPs. The phone will also randomly freeze and I can't do anything at all then he screen will go black and back to the lock screen and it works fine. Quite frustrating!
     
  5. TheJackal thread starter macrumors member

    Joined:
    Mar 15, 2008
    #5
    I also get that problem, normally after ending a call the screen goes black (but active).

    I have to lock and unlock the phone to see the home screen again.
     
  6. S1lv3rb0y macrumors newbie

    Joined:
    Aug 25, 2010
    #6
    This topic is now a Bit old but i do have the Same problem like Op.

    Not this Long, but around 2 seconds. But its annoying.

    Anyone found a fix/Solution ?
     

Share This Page