iPhone 3G and OS 3 Beta

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Croatian, May 25, 2009.

  1. Croatian macrumors 6502

    Joined:
    Oct 14, 2006
    Location:
    Ontario, Canada
    #1
    i currently have OS 3 Beta 4 7a300g installed. today however the iphone went into a restore mode. when connected to iTunes 8.2 it says software has expired. i've downloaded beta 5 software and using itunes i try to restore it to beta 5 and it comes with an error saying it can not be restored because firmware file is not compatible

    any ideas what might be happening
     
  2. weeman macrumors 6502

    Joined:
    May 6, 2007
    #2
    Make sure the file begins with 1,2 and not 1,1

    1,2 is for the 3G
    1,1 is for the 1st gen

    That's the only thing I can think of.
     
  3. RichieCat macrumors newbie

    Joined:
    Nov 15, 2008
    #3
    Try downloading the firmware update file again (just in case it's corrupted) and make sure that you select the correct version (iphone 2G / 3G etc..)

    Then click on Update whist holding down the shift key (or alt on a mac) and select the file...
     

Share This Page