iPhone 3G auto-boot keeps resetting... Confused!

Discussion in 'Jailbreaks and iOS Hacks' started by colml, Jul 20, 2010.

  1. colml macrumors newbie

    Joined:
    Jul 20, 2010
    #1
    I have a iPhone 3G on which I've installed IOS4.
    After jailbreaking it and after using it for a day or so it crashes and goes into a recovery mode loop.
    I've jailbroken it with redsn0w 9.5b5 and with sn0wbreeze 1.7 but the problem still occurs.
    After the phone crashes I can't restore with itunes.
    I've tried manually setting the auto-boot=true with irecovery, this then lets me restore to the factory settings.
    I can then jailbreak fine and install apps and make calls OK for around 1 day and then it just crashes again.
    The crash trigger doesn't seem to be anything specific, I was making a phonecall the first time it happened, downloading an app the second time, etc...
    I've searched everywhere for an answer but nobody seems to have this specific problem. The "recovery mode loop" apparently can usually be solved using iRecovery and setting the auto-boot=true. This doesn't do anything except allow me to restore from recovery mode via iTunes.
    Any help or pointers in the right direction would be greatly appreciated.
    Cheers,
    Colm
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Why don't you go back to 3.1.2 or 3.1.3 and try the phone, see if it's still doing it.

    That's what I would do.
     
  3. colml thread starter macrumors newbie

    Joined:
    Jul 20, 2010
    #3
    I'm currently testing a standard installation of ios4 on the 3G to see if it will remain stable. It's been ok for almost a day now.
    As far as I can tell something was triggering the auto-boot in iboot to set to false during normal use of the jailbroken phone.
    If this fails i will downgrade to 3.1.3 to see if that solves the problem.
    If it doesn't fail then it was the jailbreak crashing the phone into a recovery loop after a day or two of use which I think is strange because it happened with 2 different jailbreak tools. :confused:
     
  4. colml thread starter macrumors newbie

    Joined:
    Jul 20, 2010
    #4
    Hmmm...

    Well the phone crashed after approx. 2 days of use with ios4 installed.
    I'm currently downgrading the firmware to 3.1.3 to see if I have any luck.
    I'm starting to think this could be a hardware problem since it was just the stock ios4 installed and it reverted back to recovery mode.
    Any ideas?
     

Share This Page