Iphone 3G Battery/Charging/Call Problems?! [REPLACEMENT]

Discussion in 'iPhone' started by DannehB, Jun 28, 2009.

  1. DannehB macrumors newbie

    Joined:
    Sep 3, 2008
    #1
    So long story short on Saturday, I got a replacement Iphone free of charge from the Apple Store due to a wifi hardware problem but now I face more problems...

    I woke up the next morning (Charging over night) to find the battery was still on red even though it was plugged in all night.. I thought maybe it was the usb lead so tried restarting it and plugging it into computer for a few hours, all seemed okay. Then about 3-4 hours later, I received all of last nights and this mornings texts.. It was like they didn't come through cause it was on charge..

    Anyway, came home today and battery was low, Plugged it in charge about 3 hours ago but its still on red and I have asked people to try ring/text me and I have not received anything even though they are certain they have..

    Any tips?

    I have tried restoring and restarting but no luck..?!

    I don't really want to make another trip to apple store!

    Thanks!
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    You got a bad refurb.
     
  3. DannehB thread starter macrumors newbie

    Joined:
    Sep 3, 2008
    #3
    does this happen a lot?

    It was fresh out a small brown box although it was fully charged?!

    Definitely brand new, not a single marking anywhere.
     
  4. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #4
    Supposedly, white boxes are for refurbs, and black boxes are for new phones. Brown boxes.......who knows?
     
  5. DannehB thread starter macrumors newbie

    Joined:
    Sep 3, 2008
    #5
    update:

    I restarted the iPhone and it's now managed to get to a small amount of green so I'm hoping it will now fully charge!

    However, all my calls are going straight through to voicemail..

    I've tried turning off 3G and email push but no luck..

    any clue?
     

Share This Page