iPhone 3G - Blackra1n - Simple Fix!

Discussion in 'Jailbreaks and iOS Hacks' started by StickyTape, Oct 12, 2009.

  1. StickyTape macrumors newbie

    Joined:
    Oct 12, 2009
    #1
    Here is a simple work around for people having problems with Blackra1n and the iPhone 3G:

    1. Restore a clean build of 3.1.2

    2. Close iTunes

    3. Copy Blackra1n.exe to C:\ and run as Administrator (No need to run as admin for XP users)

    4. Click "Make It Rain"

    5. Wait for the phone to shut down, then instanly press and hold POWER + HOME

    6. As soon as the Apple logo appears, let go of POWER but keep holding HOME until the Blackra1n logo appears on the screen.

    7. Enjoy :)

    Worked perfectly for me on Windows 7.
     
  2. LiquidHonesty macrumors newbie

    Joined:
    Jul 17, 2008
    #2
    You ROCK! The other thread didn't work for me, but this one did! Thanks!
     
  3. sparky7 macrumors member

    Joined:
    Jul 10, 2008
    #3
    I did this and this was the only way I could get it to work, but iTunes won;t let me restore my backup to it? Any way around it?
     
  4. redbeard331 macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #4
    Wow, I've tried everything, this is the only thing that worked..:cool:
     
  5. BergerFan macrumors 68020

    BergerFan

    Joined:
    Mar 6, 2008
    Location:
    Mos Eisley
  6. qawsed macrumors regular

    Joined:
    Jul 9, 2009
    #6
    Thanks man, was sticking in recovery mode before I tried this. Working now.
     
  7. Slav2009 macrumors member

    Joined:
    Jul 18, 2009
    #7
    Will this work if you rely on ultrasn0w for unlock??

    I have a 3G from the US, but I unlock it and use it in Australia (I need to Hactivate I guess??)

    Please clarify
     
  8. Goodeye macrumors 6502a

    Goodeye

    Joined:
    Jan 30, 2009
    #8
    I tried 30 time (no kidding) and nothing worked. What your talking about is DFU mode and by god if this works when I get home from work, I will donate to you not the weirdo who slapped his frodo baggins face on this dang freaking jailbreak stuff. The fact he didn't do more quality testing before rushing this out totally kept me from wanting to donate to him.

    NO NO NO this is purely a jailbreak NOT I repeat NOT a unlocker. Upgrading to 3.1.2 will upgrade your baseband therefore making it almost next to impossible to unlock.
     
  9. DrawnToLife macrumors regular

    Joined:
    Aug 17, 2009
    #9
    This is strictly a jailbreak, and not an unlocking.
    If you rely on ultrasn0w, don't upgrade :/
     
  10. Slav2009 macrumors member

    Joined:
    Jul 18, 2009
    #10
    Well I am happy with 3.0 and I have no problems at all with battery, or stability or anything really. There is no point to risk upgrading for me, so I'll stay on 3.0 until a proper unlock is available I guess. No hurry here :)
     
  11. drerandom macrumors newbie

    Joined:
    Oct 12, 2009
    #11
    This will fix that
    http://www.youtube.com/watch?v=w8UYSfPEKnQ
     
  12. drerandom macrumors newbie

    Joined:
    Oct 12, 2009
  13. Goodeye macrumors 6502a

    Goodeye

    Joined:
    Jan 30, 2009
    #13
    Neither of those worked. I'm on vista Im going to try on windows 7 with a newly fresh install of itunes on that windows 7 computer and hope for the best.
     
  14. bruinsrme macrumors 601

    bruinsrme

    Joined:
    Oct 26, 2008
    #14
    I had a ton of problems.

    I tried turning off a bunch of services and whatever else. After HOURS of jumping thorugh hoops all the services were started with the exception of Bounjour.

    that worked on my 3G

    On the same computer I JB'ed a 3Gs in under a minute.

    props to Geohot but why are some methods work for some while others don't is odd. But at least he is giving windows users the ability to jaibreak.
     
  15. Goodeye macrumors 6502a

    Goodeye

    Joined:
    Jan 30, 2009
    #15
    Well windows 7 is what worked. I had to do the whole power and home thing twice and on the second try did I see geohots fugly weird ass picture (seriously dude enough with the ego, secondly no one wants to see your picture on our iphones.
     
  16. TtOrMaMnY macrumors member

    Joined:
    Jun 10, 2008
    #17


    wow this was the only method that worked for me!!!
     
  17. ryguy2303 macrumors 6502

    ryguy2303

    Joined:
    Jul 27, 2009
    #18
    Ugh. Nothing is working for me. Tried about 15 times. Talk about frustrating.
     
  18. Stier macrumors member

    Joined:
    Sep 15, 2008
    #19
    same here, most of the people here keep saying "Worked on Windows 7"

    i'm on Vista and i did the Windows Compatibility XP Service Pack 2 and Run as Administrator stuff and nothing...
     
  19. ryguy2303 macrumors 6502

    ryguy2303

    Joined:
    Jul 27, 2009
    #20
    I'm on XP and did the same thing…nothing happens. Pretty busty. Weird how it's only for PC right now.
     
  20. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #21
    This is the way to go. Just keep trying.

    Took me nine times. I think.
     
  21. Stier macrumors member

    Joined:
    Sep 15, 2008
    #22
    so just keep the blackra1n window open (while it says entering recovery mode) and keep doing the Home+Power, then hold Home button combo?
     
  22. ryguy2303 macrumors 6502

    ryguy2303

    Joined:
    Jul 27, 2009
    #23
    I click make it rain, and it just stays on "entering recovery" or whatever and whatever combination of pressing buttons I do has zero affect. I have to go and restore. I've tried it all.
     
  23. StickyTape thread starter macrumors newbie

    Joined:
    Oct 12, 2009
    #24
    Haha! Why didn't I think of that? Well, if anyone wants to, they can go here ;)
    Yep, that's all you have to do. If you close blackra1n or kill any iTunes services, it won't work.
    Don't put it in compatibility mode. Just put it in C:\ and run as admin.
     
  24. anthdci macrumors 6502

    Joined:
    Jun 8, 2009
    #25
    arrgggg, i still cant get this to work. ive tried on my XP work pc and my win7 and it just keeps going to the restore/ connect to itunes screen. I must have tried this about 20 times :(

    EDIT: done it!
     

Share This Page