iPhone 3G Data recovery while in recovery mode

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Merklynn, May 25, 2013.

  1. Merklynn, May 25, 2013
    Last edited: May 25, 2013

    Merklynn macrumors newbie

    Joined:
    May 25, 2013
    #1
    Hi, I know similar to some other problems on here but I cant seem to find a solution to my specific issue:

    My iphone: Iphone 3G on IOS 3 Jail broken for many years (I know old but I just never got round to upgrading).
    My comp: Windows 7 64-bit

    I recently deleted an an app off of this device, all was well till it ran out of power. I tried to recharge it over night though thought it was strange it didn't turn on when I plugged it into the wall and no charging symbol appeared. Went to turn it on in the morning and the apply logo was displayed for around 20 seconds and then it turned off. I have tried doing this multiple times and it just does the same thing.

    I can get into recovery mode, if I boot into this it stays on for about 15 minutes if I do nothing. Itunes detects it and asks if i want to perform recovery but I think this wipes it, is there anyway for me to take the data off of the device while in this mode (I have tried iexplorer, iphone explorer and ifunbox but they wont detect the device in recovery mode). Tiny Umbrella lets me exit recovery mode but then I just get the apple for 20 seconds or so again before it turns off. If I plug it in no charging symbol appears still (either via usb or wall charger).

    Thanks in advance
     
  2. MrMacMack macrumors 6502a

    Joined:
    Oct 24, 2012
  3. Merklynn thread starter macrumors newbie

    Joined:
    May 25, 2013
    #3
    Hi

    Thanks for your response, I have got a bit further with this (I have never had to do this before so learning along the way). Anyway, I have managed to use a tool to create a ramdisk and then get into the device in dfu mode with SSH. Using PuTTY I can run mount.sh which then mounts what I think is the system partition so I can then login using WinSCP and I get a load of files present in mnt1, it fails however when it comes to mount disk0s2 (comes to "Checking catalog file" and I get "Invalid sibling link (4, 6203)", "Rebuilding catalog B-tree", "The volume Data could not be repaired", "Mounting /dev/disk0s2 on /mnt2", "mount_hfs: Invalid argument". I've tried running fsck_hfs -r on disk0s2 a few times (I guess this is like chkdsk) but I always get "The volume Data could not be repaired" and then if I try to mount again I get the same invalid argument error.

    Do you have any ideas how I can get by this?

    Thanks in advance
     
  4. alifenorm macrumors newbie

    Joined:
    Aug 20, 2013
    #4
    Hi,
    I got about the same problem recently (no app deletion, simply the phone run out of power and never shaked out connect to itunes status).
    my phone wasn't jailbreaked.
    I was able to access ssh like you and got stuck with broken catalog.
    accessing the ramdisk in read only mode did the trick for me
    in this page
    http://msftguy.blogspot.it/2012/01/automatic-ssh-ramdisk-creation-and.html?commentPage=2
    look for the comments of pat mez arond the beginning of october 2012.

    I was then able to extract the data I wanted.
    what I am looking for now is a toll to fix the broken catalog btree, tried fsck_hfs on the disk before mounting but no result.
    anyone has any idea about repairing/fixing the broken file system?

    fsck_hfs output
    ** Checking non-journaled HFS Plus Volume.
    ** Detected a case-sensitive volume.
    ** Checking extents overflow file.
    ** Checking catalog file.
    Keys out of order
    (4, 1831)
    ** Rebuilding catalog B-tree.
    ** The volume Data could not be repaired.

    (note I am not a tech guy, so I come up with this after extensive reading and some trial end error)
     

Share This Page