Iphone 3G ~ Im stuck in DFU (?) mode?

Discussion in 'Jailbreaks and iOS Hacks' started by OrangeShark, Jul 27, 2009.

  1. OrangeShark macrumors newbie

    Joined:
    Jul 27, 2009
    #1
    I have a jailbroken iphone 3g and i wanted to restore it to update to version 3.0 . Suddenly an error shower up saying that my iphone could not restore. So i took my iphone off the usb.as i did so the screen lit up and showed me a picture of a normal usb ( not the one you connect to the iphone but the one you connect into your pc) and an arrow on top of it in the direction of an itunes symbol!
    When i tried reconnecting the iphone itunes did not open automatically, and does not find an iphone inserted! My PC finds a usb device but even when i try to download the hardware it says no hardware found! PLEASE HELP ME!!!!!
     

    Attached Files:

  2. The General macrumors 601

    Joined:
    Jul 7, 2006
    #2
    What is the error code? What version of the firmware did you have on it last?
     
  3. blaker13 macrumors member

    Joined:
    Jun 3, 2009
    #3
    hmm...

    Will it power off and reset if you hold the power and home button? You could also try and run redsnow or a jailbreaking program to get it out of that state, might read it... but try to hold power and home while plugging in usb....
     
  4. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #4
    Am I being stupid, or is that just the activation screen?
     
  5. sparrky macrumors 6502a

    sparrky

    Joined:
    Oct 23, 2008
    Location:
    California
    #5
    Does it say "slide for emergency" on the bottom?

    The same thing happened to me last week. I was still on 2.2 and downloaded something from cydia only meant for 3.0 and it killed my phone. First it was stuck at the apple logo, then it went to the connect-to-itunes logo (without "slide for emergency"). I was starting to panic because nothing was working, so I wish I could remember the exact order I did things but I know I followed the jailbreak tutorial from iclarified with redsn0w to see if it would revive it (it didn't but it did get rid of the "connect to itunes" logo), and between that and several more attempts at putting it DFU mode, itunes finally recognized it and I just updated/restored through there. Then I was back to "connect to itunes" BUT this time with the "slide for emergency" at the bottom so all I needed was activation. I have Tmobile so I have to jailbreak in order to "hacktivate" so from there I went back and jailbroke with redsn0w and finally it did the trick.

    Hopefully someone can offer more specific instructions, but until then, just keep playing with DFU mode and redsn0w. Good luck! :eek:
     
  6. impulse462 Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #6
    That is recovery mode not DFU. To get out of recovery mode and into dfu mode first connect your phone to your computer. Then hold down the home and power buttons for 10 seconds. Then release the the power button and continue holding the home button till iTunes says it's detected a phone in recovery mode. If your screen REMAINS BLANK(black), you are successfully in dfu mode and you can restrore
     
  7. OrangeShark thread starter macrumors newbie

    Joined:
    Jul 27, 2009
    #7
    Thanks!

    thanks to those who replied. apparentely its my pc fault because i tried connecting my iphone with another pc and itunes opened up. I pressed restore and update and now its ok. im waiting for itunes 8.2 to download so my sim will work :p ill keep you informed if it works! Thanks again
     

Share This Page