iPhone 3G iOS 4.1 running 6.15 baseband "no service" error

Discussion in 'Jailbreaks and iOS Hacks' started by Keegan Lodder, Dec 19, 2010.

  1. Keegan Lodder macrumors newbie

    Dec 13, 2010

    My iPhone 3G is running iOS 4.1 with the baseband update 6.15
    in the About section I can see it identifies Carrier: "Bell 8.0".

    I've tried the three popular methods that are supposed to fix "no service"
    which include,
    1. installing fuzzyband
    2. disabling 3G and rebooting
    3. reset all setting, reset network settings

    none of these methods have worked,
    I did have the iPhone unlocked and working (on Bell) for somwehere around 36 hours, but it suddenly dropped the network and, although it still identifies the Bell network, it is unable to connect to it.

    any ideas?
  2. SavMBP15 macrumors 6502

    Mar 26, 2010
    Baseband 06.15 is only if you went up to 4.2.1 I thought. Maybe I'm wrong, but that could be your problem.
  3. Magnum.Handy, Dec 29, 2010
    Last edited: Dec 29, 2010

    Magnum.Handy macrumors newbie

    Dec 29, 2010
    Negative.... I'm on 4.1 w/ 6.15 baseband and up and running on TMobile.

    However, I do have another iphone 3g with the same specs that has the "no service" issue.

    Try to run redsnow again and ONLY check "update to iPad baseband".

    That has worked for me before.. but (obviously) not every time.


    if you have fixed this already, please share your exp. ;)
  4. cjmorry macrumors newbie

    Jan 7, 2011
    Carrier Bell 8.0 when using Virgin network

    This may be totally irrelevant but I also have an iPhone 3G on iOS 4.1 that I (foolishly) upgraded to the 6.15 baseband in order to unlock it. Should have waited. And yes it is possible to be on 4.1 still after upgrading to the 6.15 baseband, but it does not seem to be possible to upgrade to 4.2 once you have done this. I also see Carrier Bell 8.0 though I am operating on a Virgin SIM. The phone works OK in all departments but is sluggish after the upgrade. Wish I had not done it.

    Interesetingly, when you go to settings-phone and select "home" this takes you to Bell's homepage, not Virgin's. I've complained about this to Virgin. At first they said it was because the phone was originally on Bell before being unlocked -- it never was; it was on Rogers before. Now they say they don't know why it is happening or how to fix it. They never admit that it is most likely because they are all part of Ma Bell's big happy family!

Share This Page