iPhone iPhone 3G jailbreak problem

xGaZiino

macrumors newbie
Original poster
Oct 22, 2012
7
0
I jailbreaked my iPhone 3G using redsn0w and i'm unsure of the details but it was jailbroken in an iPad format or something similar to that nature.
I was using iOS 4.2.1 at the time.

The phone was working for a while but recently, it crashed. I held down the power button to turn it off, but instead the black screen with the circular loop loading icon in the middle. I waited for an hour and it still didn't go away so i tried restoring my iPhone. When the restore was about to finish an error came up: I cant remember wording but it involved error 1015 and the phone went to restore mode (insert into itunes icon). Whenever i restart the phone it gets stuck at the apple logo loading screen. I have no idea what to from here on.

Any help would be greatly appreciated :)
 

gngan

macrumors 68000
Jan 1, 2009
1,828
72
MacWorld
What firmware were you trying to restore? Does the phone have iPad baseband? Try putting the phone in DFU mode and restore.
 

xGaZiino

macrumors newbie
Original poster
Oct 22, 2012
7
0
sorry im not to familiar with iphone software. im not sure what baseband to restore it to, and it doesnt really matter as long as it works (preferably the default baseband when first purchasing the phone). yes it has ipad baseband. ive tried restoring it through itunes before but i got the 1015 error, however that was always when the phone was off, i'll try doing it in dfu mode now.
 

TriJetHero

macrumors 601
Oct 13, 2010
4,953
141
World
Create a NO_BB custom IPSW to restore with redsn0w or use sn0wbreeze.

The error 1015 is becaus you have a higher BB than the iOS firmware and it will error out on it.

Check iclarified.com for tutorials
 

xGaZiino

macrumors newbie
Original poster
Oct 22, 2012
7
0
ive got one more question - which ipsw would you recommend i use to create the custom no_bb ipsw off?
 

xGaZiino

macrumors newbie
Original poster
Oct 22, 2012
7
0
i cant restore the ipsw because i cant enter dfu mode. i hold down the power button, but when i start pressing the home button and power simultaneously, it just goes to restore mode. After the third try, instead of going into restore mode, it just goes to WTF mode.
 

xGaZiino

macrumors newbie
Original poster
Oct 22, 2012
7
0
haha sorry if that confused you, basically i cant enter dfu mode, whenever i hold the home and power at the same time it just says usb connection problem
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.