iPhone 3G keeps defaulting to time zone Cupertino

Discussion in 'iPhone Tips, Help and Troubleshooting' started by markfraser, Jul 16, 2008.

  1. markfraser macrumors newbie

    Joined:
    Jul 12, 2008
    #1
    I noticed my mail is showing the wrong 'received' time. On receiving a mail, it shows the received time several hours before the current time on my phone. The time on my phone is correct.

    So I looked in the time zone settings and it is set to Cupertino. I have repeatedly set this to London or Edinburgh but when I go to mail, the times are still wrong. When I return to Prefs, the time zone has reset to Cupertino. I have tested all this loads of times and my changes seem to stick until I go to Mail. As soon as I do this, it revert to Cupertino. This happens regardless of the Time Zone Support settings in mail.

    I searched the forum and can't find anything on this so I must be missing something very obvious - but what?
     
  2. SilentPanda Moderator emeritus

    SilentPanda

    Joined:
    Oct 8, 2002
    Location:
    The Bamboo Forest
  3. FlyingGoose macrumors newbie

    FlyingGoose

    Joined:
    Aug 13, 2008
    #3
    Samething

    I have the same issue, but I'm off to the Mac Bar tonight when I finnish work. just out of intrest did you ever reset your phone? As I think this issue started after I reset my one.

    will let you know how I get on.
     
  4. itsmiPhone macrumors newbie

    Joined:
    Aug 14, 2008
    #4
    I've been stuck in Cupertino Time Zone since I reset my phone.

    I reset my iPhone last week after it locked up answering an incoming call while I was composing an SMS. The phone locked and the screen went dead. I tried switching off, but no response. I plugged it into my mac to see if it was still alive and it came up in itunes, ready t sync as if there was no problem at all. But I could not access the phone from it's screen. I read about the reset in the Apple online iPhone Troubleshooting Assistant and performed the reset holding the Home and Sleep/Wake buttons for 10 seconds.
    Since then I have been stuck in Cupertino. Resetting the Time Zone to Melbourne Australia, works, but as soon as I leave the settings app my Time Zone resets to Cupertino. I have upgraded the software to 2.0.1 expecting a bug fix, but no luck there.
    Tried submitting a fault with Apple but could not find a TAC for iPhone OS, only hardware. Any ideas?
     
  5. FlyingGoose macrumors newbie

    FlyingGoose

    Joined:
    Aug 13, 2008
    #5
    Sorted

    After the visit to the genius bar all, they reset the phone from iTunes and changed the location back to London. Got home then restored the phone from backup and all has been well.

    it seems that this fault is happen after reseting the phone from the handset.
    :D
     
  6. keironwaites macrumors newbie

    Joined:
    Sep 3, 2008
    #6
    Hi guys. I was having the same problem and I managed to fix it myself. I wrote a guide on how to fix the problem which has helped a few other people including some work friends.

    Check out the fix here: iPhone time zone stuck in Cupertino bug fix

    If you have any problems with the instructions please post here or on my blog post and I'll see if I can help further.
     

Share This Page