iPhone 3G no longer playing internet video, m4v, qt,m4p (not talking bout flash/java)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by AlienBaby, May 6, 2010.

  1. AlienBaby macrumors newbie

    Joined:
    May 6, 2010
    #1
    At some point, my iPhone 3G just stopped playing (iPhone playable) internet videos. I thought with updates or restarts this issue would fix itself but it hasn't. My only work around is using the Privately app, which still gives me errors before ultimately playing the video. And this is not really a fix because the app restarts itself anytime you get a text, call, push notification, etc. and it's a pain.

    On Safari, if I click on an internet video, I end up with a page entirely filled with random code, or letters, numbers, anything a keyboard can dish out. I've tried searching online for some of the codes and I get nothing. It always starts with "ftypisom" which I've read online means the video isn't encoded properly. But that doesn't make sense for my situation. How can every video on the internet made for iPhone not be encoded properly. Catch my drift? It's my phone, not the videos.

    On Privately, I get this error before the videos finally play: "Cannot Load Page: The browser cannot open the page because it could not connect to the web server." But the video commences to play anyhow.

    Does anyone know what's going on?

    Now, just to clear things up, I am aware the iPhone does not play java or flash. That's not what I'm talking about.

    Thanks,
    AB
     
  2. rinnin macrumors newbie

    Joined:
    Jul 25, 2002
    #2
    Internet video stopped on iPhone 3Gs too

    That's really weird. Exact same thing just happenned to me this morning. Was working fine yesterday. :(
    Not even trailers in Apples site work anymore. Tried restarting the phone and trying again but still have the same problem. Might try resetting it but as it didn't make any difference to you I don't know what that'll achieve.
    So strange... :(
     
  3. rinnin macrumors newbie

    Joined:
    Jul 25, 2002
    #3
    Fixed it!

    Just went to settings>safari then click on allow Internet plug ins. Don't remember ever turning it off strangely!
     
  4. AlienBaby thread starter macrumors newbie

    Joined:
    May 6, 2010
    #4
    Thanks!

    AWESOME. I haven't tried to see if it works, but I too had the setting turned off for some reason! And the weirdest thing was how many reads this post got with zero replies. I guess it's not common.

    Thanks for your help!
     
  5. orpheus1120 macrumors 65816

    orpheus1120

    Joined:
    Jan 23, 2008
    Location:
    Malaysia
    #5
    I've encountered the same problem before.

    Goto Settings>Safari and clear History, Cookies and Cache.

    That should solve your problem.
     
  6. AlienBaby thread starter macrumors newbie

    Joined:
    May 6, 2010
    #6
    Did not work...

    I tried clearing cache, updating, everything other than the first solution listed here. But thank you, hopefully clearing cache/history works for others with this prob!
     

Share This Page