iPhone 3G not being upgraded to 4.0

Discussion in 'iPhone' started by ishtahir, Nov 4, 2010.

  1. ishtahir macrumors newbie

    Joined:
    May 21, 2010
    #1
    I've got an iPhone 3G with version 3.1.3 on it, and i'm trying to upgrade it to 4.0, or 4.0.1 but it keeps telling me 'this device isn't eligible for the required build' i have itunes 10.1 b2 and osx 10.6.4 any help please!!
     
  2. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #2
    Just a guess, but if you have the newest iTunes and the newest Mac OS, perhaps it will only let you use the newest iOS?

    Why aren't you trying to upgrade to 4.1?
     
  3. ishtahir thread starter macrumors newbie

    Joined:
    May 21, 2010
    #3
    well because i'm trying to unlock it and 4.1 updates the baseband which can't be unlocked at this time!
     
  4. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #4
    You should probably ask this question in the forum where people have the most experience with that:

    http://forums.macrumors.com/forumdisplay.php?f=105
     
  5. ishtahir thread starter macrumors newbie

    Joined:
    May 21, 2010
    #5

Share This Page