iPhone 3G not recognized as USB peripheral

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Shlen, Oct 5, 2010.

  1. Shlen macrumors newbie

    Oct 5, 2010
    Recently, some time after upgrading to iOS 4.1.2, my iPhone 3G is no longer recognized by my Mac as a USB peripheral and cannot charge using the computer. It is able to charge using the charger plugged into the wall, and it is also recognized by my clock radio and capable of playing music through the radio's speaker. But when I plug it in to my Mac, or into another Mac, regardless of the cable (I've tried several), it is not recognized by the computer and does not recognize that it is attached to a computer.

    I am guessing that this is a hardware issue because I've tried plugging it in to several computers using several different USB cables with the same result every time. Perhaps some small filament has broken internally that is needed for USB charging and syncing. But are there others in this forum who have a different diagnosis or who have experienced this issue?

    Thank you.
  2. blackscorpio111 macrumors newbie

    Oct 5, 2010

Share This Page