IPHONE 3G on iOS 4 - 3g Internet not working (AT ALL)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jmxflu, Jul 15, 2010.

  1. jmxflu macrumors newbie

    Joined:
    Jul 15, 2010
    #1
    No Safari, Faebook etc apps work but WiFi DOES work.

    I am looking to sell my phone and I need to know if this is a temporary issue or if there is something wrong with my phone specifically.

    I have tried restting network settings, and I have also tried restoring.

    Can anyone confirm if this is a known issue?


    if I keep letting the web page attempt to load, it says 'the sever stopped responding'
     
  2. Mwl2015 macrumors newbie

    Joined:
    Jul 10, 2010
    #2
    I'm having the same problem with my iPhone 4, except mines says it can't connect to network. I called customer service but they couldn't help either
     
  3. King Luis macrumors 6502

    Joined:
    Jul 3, 2008
    #3
    i'm having the same issue with my 3g.

    i noticed that when i reset my network settings (or reset my phone) everything works again.

    i reset all my settings last night and haven't had the issue yet. giving it a few days to see though.
     
  4. Mwl2015 macrumors newbie

    Joined:
    Jul 10, 2010
    #4
    I reset all my network setting and they still didn't work for me
     
  5. jmxflu thread starter macrumors newbie

    Joined:
    Jul 15, 2010
    #5
    RESET NETWORK SETTINGS = NOT WORK

    Restore = Not work

    Updating to 4.0.1 = Not work

    Any help?
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    You restored and setup as new right?
    Not from backup.
    Do you get any edge data or no carrier data at all?
    MMS messages go thru? Visual voicemail working?
    It might be a hardware issue or a carrier issue so calling your wireless provider might help.
     
  7. kuaiyouming, Jul 15, 2010
    Last edited: Mar 24, 2013
  8. jmxflu thread starter macrumors newbie

    Joined:
    Jul 15, 2010
    #8
    ahh I did restore as a backup, I will try as new and report back.

    edit: also, just checked and Visual Voice mail is NOT working, SMS works.
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #9
    Restore as new to make sure no bugs carried over from previous os versions. Also calling AT&T might also help to make sure everything is ok on their end.
     
  10. jmxflu thread starter macrumors newbie

    Joined:
    Jul 15, 2010
    #10
    Ok, restore as new brought it back. Thanks for the help - I should have noticed that.

    Thanks a lot, I tried some other forums and literally didnt even get a response. I really appreciate the help.
     
  11. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  12. narimonk macrumors regular

    narimonk

    Joined:
    Jul 15, 2010
    Location:
    Sacramento, CA
    #12
    I had this problem with my 3GS when I updated to iOS4, I found that trying to restore from one of my old backups would cause my cellular data to stop working, but setting up as new cleared up the problem. So I'd just stick to setting it up as new. :)
     
  13. stellajenna macrumors newbie

    Joined:
    Nov 10, 2010
    #13
    3G internet not connecting but wi-fi is?

    When I first got my iphone4 everything was in working order, then a couple of weeks ago I noticed that it wouldn't connect to the internet when wi-fi was not accessable. In other words I couldn't connect via 3G.

    I rang 02, my network provider, who kindly put me through to apple. I was advised to:

    turn off the wi-fi in settings. Press and hold the main menu button and the on/off switch simultaniously (until a white apple symbol appears). Once this appears you can release the buttons. Give it 20-30secs then your phone should re-boot. Notice the icons in the top right hand side, the 3G icon should reappear and your connection should now work.

    Pressing and holding the menu and on/off switches simultaniously should be carried out anytime your phone freezes/crashes. It sort of 're-boots' the system, like you might do with a computer.

    Hope this is helpful :) :apple:
     

Share This Page