iphone 3g on tmobile 2.2.1

Discussion in 'Jailbreaks and iOS Hacks' started by nate1220, Mar 9, 2009.

  1. nate1220 macrumors member

    Joined:
    Mar 9, 2009
    #1
    hey guys. first post actually!
    ive been doing some research and i cant really find the solution. i've been searching on the forum for awhile.

    a cousin of mine actually gave me his 3g for a really good price. so i took it.

    i knew that the 3g network would not work on t-mobile so i guess im stuck with edge.

    on the other hand. it is upgraded to 2.2.1 firmware and the baseband is 2.30

    I was wondering if you can unlock this. i know that it is able to jailbreak but can you unlock it?

    thanks again guys
    im on a mac and am also able to get onto xp so either versions of quickpwn or whatever is available. thanks again guys.
     
  2. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #2
    I believe yellowsnow is what you are looking for, but the iPhone cannot be JB on 2.2.1 firmware until after the yellowsnow unlocks the iPhone, JB must be done with 2.2 firmware. Just do a google search or you can search the forums here...
     
  3. nate1220 thread starter macrumors member

    Joined:
    Mar 9, 2009
    #3
    hmm ive been researching and it seems like yellowsnow only works for 2.2. as well.

    do you know when an update for the baseband 2.30 and version 2.2.1 is going to released? thanks again
     
  4. iTouch macrumors 6502

    Joined:
    Sep 12, 2007
    #4
    They're working on it but no firm date. I suggest you try eBay and buy Turbo SIM for $10. It's well worth it to use the iPhone.
     
  5. WRXface macrumors regular

    Joined:
    Aug 6, 2008
    #5
    same here, everywhere i look, they say you can use 2.2.1 but the baseband cant be 2.30.00 it has to be 2.28.00. the jailbreaking tutorials tell you as long as you dont update the baseband your all good, it just seems like someone did do that but i cant find it, they probably are working on it.

    EDIT:
    i guess you gotta downgrade to 2.2.0 and use yellowsn0w and just stick with 2.2.0
     

Share This Page