iPhone 3G OS 4.2.1 no signal/texts/3G

Discussion in 'iPhone Tips, Help and Troubleshooting' started by verveguitar, Dec 19, 2010.

  1. verveguitar macrumors newbie

    verveguitar

    Joined:
    Sep 16, 2009
    Location:
    London
    #1
    I've literally just upgraded my iPhone 3G to OS 4.2.1 and now I appear to have no signal whatsoever? Is there any way of fixing this or am I now going to have to fork out for an iPhone 4?
    :(
     
  2. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #2
    Was your phone jb/software unlocked? If so, you just screwed yourself (and not in the good way).
    You can fix it, but it'll be a PITA
     
  3. verveguitar thread starter macrumors newbie

    verveguitar

    Joined:
    Sep 16, 2009
    Location:
    London
    #3
    No it wasn't jailebreaked or unlocked its the original since I got it brand new on my contract.

    Glad to hear it can be fixed! What's the procedure?
     
  4. verveguitar thread starter macrumors newbie

    verveguitar

    Joined:
    Sep 16, 2009
    Location:
    London
    #4
    just got it to work...:D

    I reset the phone: Settings, General, Reset.

    Then turned the phone off, and took out the sim card.
    I then put it back in and turned it on.
    Then I went to, General and turned it on airplane mode, then turned airplane mode off and it worked!

    all my texts and voicemails are coming through as I type!
     
  5. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #5
    Congrats for figuring it out. You're lucky that it wasn't jb/unlocked. That's where the PITA comes in. Sometimes you just need to restart your iphone, because of wonkiness.
     

Share This Page