iPhone 3G phone icon disappeared & cannot unlock after updating

Discussion in 'Jailbreaks and iOS Hacks' started by bkabbabe, Sep 11, 2010.

  1. bkabbabe macrumors newbie

    Joined:
    Sep 11, 2010
    #1
    Hi All,

    I have an iPhone 3G which I unlocked a year ago. Last night I decided to update to ios 4.0.2, then it got locked and I could not use it. Luckily I had a sim from the service provider who i bought it from which enabled me to turn on the phone. I used guidelines from the net and downloaded redsn0w and then os 4.0 which enabled me to open the redsnow finally and of course connected my iphone to my book pro. i went over all the steps and thought I am done after saw the Cydia icon on my iphone (which disappeared during the update)..the only weird thing is that the cydia icon was white not dark red as usual. then i tried opening cydia and follow the step to go to manage etc and enter the famous "http://repo666.ultrasn0w.com" the result was i got did not find repository and also later i found out that i cannot see my phone icon on the iphone...
    if it helps i was following this site

    http://www.ithinkdiff.com/unlock-iphone-3g-with-ios-4-0-2-using-ultrasn0w-1-1-1-2142/

    please help me....i need to get the phone running have work tomorrow and need it badly

    thanks
     
  2. bkabbabe thread starter macrumors newbie

    Joined:
    Sep 11, 2010
    #2
    hopeless??

    is it a hopeless case guys? i see a lot of ppl read it but no suggestions???

    kindly let me know

    thanks
     
  3. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #3
    Isn't 4.0.2, just to plug up the hacking hole that jailbreakme was using, and the PDF patch that you could have just gotten on Cydia? Why would you update to it if your phone was working fine??
    And try and install categories if you have access to Cydia still and don't have it installed already, or Sbsettings? It has Poof in it's setting to allow you to turn it back on.
     
  4. bkabbabe thread starter macrumors newbie

    Joined:
    Sep 11, 2010
    #4
    screwed?

    I dont understand??? Am i screwed now? at least how can I recover my contacts....
     
  5. TheConfuzed1 macrumors 6502a

    Joined:
    Jun 4, 2003
    #5
    You don't need Categories.

    Poof is part of Boss Prefs.
     
  6. bkabbabe thread starter macrumors newbie

    Joined:
    Sep 11, 2010
    #6
    Thanks but I still not understand...can someone give me a step by step procedure?

    I know I might be a pain but I am not an expert as you guys...

    tks a lot in advance
     
  7. lokster macrumors 6502

    lokster

    Joined:
    Feb 7, 2010
    #7
    hey

    reformat the iphone using 4.0.2 official firmware.

    download it by looking for it in google.
    in itunes hold shift and press restore and select the 4.0.2 download

    then jailbreak it using redsnow 9.5.5 and point to the 4.0 firmware MAKE SURE ITS THE IPHONE FIRMWARE NOT IPOD TOUCH FIRMWARE

    then it should activate it on its own after the jailbreak is successful

    go to cydia and download ultrasnow to unlock

    then go back to cydia and upgrade all essentials

    if its still a white icon google that problem why cydia is a white icon solutions will be listed
     
  8. bkabbabe thread starter macrumors newbie

    Joined:
    Sep 11, 2010
    #8
    Thanks a lot lokster...I restored it but seems that problem with Cydia is still there..I still get the white icon and tried to enter :http://apt.saurik.com/cydia-3.7.as stated everywhere to have Cydia work but no luck...anyone else facing this problem??Any clues, hints????
     
  9. risqueal macrumors newbie

    Joined:
    Sep 17, 2010
    #9
    This will help you if you still haven't found the solution.

    Download the official iOS, which ever version you feel like.
    Connect the iphone to the computer and start iTunes.

    Put the iphone in DFU mode by:

    Holding down the home and power key.After 10 seconds take your hand off the power key and keep holding the home key down until iTunes says that it has detected a phone in recovery mode. iPhone screen should be blank (BLACK)

    Hold the "alt" key down on the mac ("shift" on Windows) and click restore.

    Then follow the screen instructions. I just did this about a minute ago.

    Let me know if this helps. Anyone who uses this method, could you please reply saying if it did or did not work, so that others can feel comfortable following it.
    ThanX
     
  10. motlatsi macrumors newbie

    Joined:
    Sep 19, 2010
    #10
    Warning After Upgrade Of 4.1

    I unfortunately followed the advise below. my phone did not have network, but still operated as an ipod using FB and all other apps, but the phone. now - its locked!

    see warning below:

    This time of year there are lots of new iPhone owners, and not everybody knows that accepting new iOS updates is the surest way to lose your jailbreak and/or unlock. While those of you who have Cydia or TinyUmbrella backups of your FW hashes will always be able to get back to 4.0.1 if you make this mistake, this doesn’t hold for unlockers. There’s currently no known way to revert your baseband — if you update your baseband you’ll lose the ultrasn0w unlock, possible forever.

    Please stay away from this 4.1 release until a safe jailbreak procedure (which also preserves ultrasn0w) is developed and released.

    P.S. There are a tiny number of iPhone3G owners who can revert their basebands due to a flaw in very early bootloaders…you will already know if you fit in this category!




     
  11. trsthiagorobson macrumors newbie

    Joined:
    Oct 14, 2010
    #11
    Restoring

    The procedure below worked for me so I could restore my iPhone 3G.
    I did the jailbreak process by using redsnow in the iOS 4.1. After that I realized the phone icon had disaperead and I coul not restore it. By using the procedure below the restore process worked but now i don`t have jailbreak anymore. How could I jailbreak my iphone 3G again in the iOS 4.1?
     

Share This Page