iPhone 3G plays music when headphones are removed

Discussion in 'iPhone' started by ineedamac, Jun 30, 2009.

  1. ineedamac macrumors 6502

    Joined:
    Jul 10, 2008
    Location:
    Ohio
    #1
    Has anyone else had this issue? Often when I remove my headphones the iPod will start playing a random song. Hardly ever the same song. It seems to be happening more and more.

    Scenario 1:
    Listen to AOL Radio app. Stop app. Remove headphones. iPod starts to play random song.

    Scenario 2:
    Listen to iPod. Stop iPod. Remove headphones. iPod starts to play random song -- not even the same artist....

    Scenario 3:
    Make call using headphones. End call. Remove headphones. iPod starts to play random song.


    I called Apple support and this has been an issue both before and after 3.0 installation. Seems to be happening more with 3.0. My iPhone has never been wet. They directed me to an Apple store. Unfortunately for me the closest Apple store is a 45 minute drive. However, the closest AT&T store is just about 10 minutes away. I am thinking of heading there over lunch.
     
  2. asmgx macrumors newbie

    Joined:
    Dec 5, 2008
    #2
    This is the exact same scenario i have
    it sucks
     
  3. isaaclimdc macrumors 6502

    isaaclimdc

    Joined:
    Jun 28, 2009
    Location:
    Pittsburgh, PA
    #3
    Oh yeah, I've noticed that, but only on 3.0. Think it's some kind of stupid bug. Hopefully they'll fix it by 3.1.
     
  4. frunze macrumors member

    Joined:
    Jul 5, 2009
    #4
    Mine continues to play music in speaker mode, same song, after I remove the headphones. My iPod Touch, however, pauses playback when I pull the headphones. I found it mildly annoying. :confused:
     
  5. braddick macrumors 68040

    braddick

    Joined:
    Jun 28, 2009
    Location:
    Encinitas, CA
    #5
    I've noticed that too and sometimes, when the volume is low I check my phone hours later and see it's been playing the iPod since then (and of course the battery is getting low).

    I even double check now and although this decreases the likelihood of this happening, it still does every now and then.

    I also figured it is a simple fix with the next update so didn't hassle Apple.
     
  6. hierobryan macrumors 6502a

    Joined:
    Jan 4, 2008
    Location:
    earth/jupiter
    #6
    I figured it has to do with the minute differences in headphone jack size. I think some smaller or larger headphone jacks might be touching something inside the headphone hole when being pulled out/pushed in, causing it to pause/play/etc.
     
  7. braddick macrumors 68040

    braddick

    Joined:
    Jun 28, 2009
    Location:
    Encinitas, CA
    #7
    Silly question (?), but if that ends up being the case can a "3.1" (or later) fix this?
     
  8. hierobryan macrumors 6502a

    Joined:
    Jan 4, 2008
    Location:
    earth/jupiter
    #8
    No. If what I say is true, it would be a problem with non-Apple hardware (headphone jack size), not software.


    Are you people using the regular Apple earbuds? When I had this problem it happened when I used my Ultimate Ears Super.Fi 4 headphones w/mic.
     
  9. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #9
    I think I saw this once with my 2G, a long time ago. IIRC, it started when I pulled out the headphone while a song was playing. The fix, I think, was to plug the Apple headphone back in, and hit the pause button (on the headphone wire, while the song was playing -- do not hit the pause button on the iPhone itself).
     

Share This Page