iPhone 3G - Problem with lockscreen, sleep, and SpringBoard

Discussion in 'iPhone Tips, Help and Troubleshooting' started by TheMuffin-Man, Jul 23, 2009.

  1. TheMuffin-Man macrumors newbie

    Joined:
    Jul 23, 2009
    #1
    So yesterday I was on my iPhone and I guess I was pressing too many things and the phone had to restart springboard, and when it did it went into safe mode. So I rebooted the whole iPhone, and when I did I realized that my SpringBoard icons had been rearranged. So I put them back to what I thought they were. Now, every time I reboot all the icons move around again. No idea why.

    Also, my lockscreen doesn't "sleep" after five or ten seconds of having it on. So when I get an alert, like a text or something, the lockscreen stays lit up until I manually turn it off.

    Also, after this I noticed all my apps from the App Store didn't work. I clicked them, and two seconds after them attempting to load it just went back to SB. I fixed this by hooking it up to my iTunes.

    I would love to know why this happened and how to fix it! Thanks in advance!
     
  2. TheMuffin-Man thread starter macrumors newbie

    Joined:
    Jul 23, 2009
    #2
    I would enjoy any help! I feel this is extremely annoying and it finishes my battery whenver I don't realize I've been texted!

    I also noticed that when I go into settings, then winterboard, and try to turn on Supreme Prefs 3.0, it doesn't stay on. I turn it on, exit, then go back, and it is unchecked again.

    This might be a completely unrelated problem, but I would love any kind of advice!
     
  3. pelicanflip macrumors 6502a

    Joined:
    Jun 24, 2009
    Location:
    NYC
    #3
    Have you tried restoring your iPhone via DFU mode? Not really sure what the issue if with your iPhone.

    If restoring doesn't work, if you're still under warranty, you could always get it replaced.
     
  4. xgus69 macrumors newbie

    Joined:
    Jun 28, 2010
    #4
    im having thesame problem with the lockscreen not sleeping.. have you found a way to fix it yet?
    edit :
    i fixed my lockscreen turned out to be because i had supreme preferences installed and i guess it does that
     

Share This Page