iPhone 3G Question

Discussion in 'iPhone Tips, Help and Troubleshooting' started by millsj, Nov 9, 2009.

  1. millsj macrumors newbie

    Joined:
    Nov 9, 2009
    #1
    I have a question about the way that my iPhone 3G has been working since I bought it last July.

    Whenever I start to use the 3g data connection, the first few attempts at connecting seem to fail, before it will finally connect.

    For a more step by step view at the problem. If I open the mail application, my phone will give an error saying:

    "The connection to the server "imap.gmail.com" failed." and give an OK option.

    After hitting OK, I can use the manual refresh button down in the bottom left corner, and get the same message again. After manually refreshing about 3-4 times, the 3g connection will finally connect and download my mail.

    I have the same issue in Safari, where the phone will say that the host is unreachable when trying to search or going directly to a website. If I start Pandora, it will fail to connect to that several times too.

    Once I do achieve a connection, I don't get this error again, until I lock my phone and re-open it and try to use the 3g connection again. When I have 3g disabled, and use the EDGE connection available to the phone, I do not experience this issue.

    I was wondering if anyone had heard of this issue before, or experienced it, or it this is not even an issue (I'm assuming that there is some sort of problem here). I've had this same problem with this phone since I bought it in July. I never experienced this with my first gen iPhone, although it didn't have 3g.
     
  2. cscturulo macrumors newbie

    cscturulo

    Joined:
    Jul 18, 2002
  3. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #3
    Sounds like a typical weak signal/network problem.
     

Share This Page