iPhone 3G showing black thumbnails for about 15 pics in camera roll

snaky69

macrumors 603
Original poster
Mar 14, 2008
5,904
481
I think the title of the thread explains a lot. I think it occured either at 4.0 or 4.0.1, hard to say. The pictures themselves work fine, I can click on any one of them and display them full screen, but their thumbnails are covered in black on the camera roll screen, so I have no idea what picture I am tapping on.

Photos taken after the "blackness" show up perfectly fine, same as the ones before it.

Any known fixes?
 

Attachments

dangson

macrumors newbie
Jul 15, 2010
26
1
I've had this problem before too. All I had to do was click Albums to switch to a different album and then go back to the camera roll. Maybe that will work for you.
 

somemightsay

macrumors newbie
Sep 5, 2008
11
0
Just upgraded from 4.0 to 4.0.1 and am experiencing the same issues as you. Looks like I have black thumbnails for all the pics I took while on the 4.0 firmware. All pics before that have thumbnails.

If you figure this out could you post back in this thread? This isn't a showstopper but it is very annoying. The move from 4.0 to 4.0.1 also hosed up some of my movie and album art on my iPhone, I ended up taking all my music and movies off of my iPhone and resyncing it to fix it. :(
 

snaky69

macrumors 603
Original poster
Mar 14, 2008
5,904
481
Just upgraded from 4.0 to 4.0.1 and am experiencing the same issues as you. Looks like I have black thumbnails for all the pics I took while on the 4.0 firmware. All pics before that have thumbnails.

If you figure this out could you post back in this thread? This isn't a showstopper but it is very annoying. The move from 4.0 to 4.0.1 also hosed up some of my movie and album art on my iPhone, I ended up taking all my music and movies off of my iPhone and resyncing it to fix it. :(
I'll definitely let you know if I find a fix.
 

somemightsay

macrumors newbie
Sep 5, 2008
11
0
I went ahead and removed the pictures in question from my phone (XP camera wizard), and then synced them back into the Photo Library. Thumbnails show up fine for them again. Like I said, it's an annoyance, but not the end of the world, at least for me. ;)
 

dissembly

macrumors newbie
Jun 19, 2010
12
0
I had this problem too; i think it might have been preventing my photo albums list from re-freshing, for some reason.

-aggie- is probably right: my favourite app is "Astronomy Picture of the Day", and downloaded pictures pretty much occupied my entire camera roll.

I fixed it by:

1. setting it so that XP's "Photo and Camera Wizard" comes up when the phone is plugged into my PC,
2. selecting all the photos in the camera roll from the wizard,
3. selecting "Delete these photos from my camera/device after downloading",

...and then just letting the wizard do it's thing.

Then i created a new folder in the folder i use to sync my photo albums, and put all my dowloaded pictures in there, so that i can still look at them on the phone.

The camera roll ended up empty, no more nonexistent blacked-out images.

----------
Edited to add:

Ah, sorry, somemightsay already said that.